aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/python-ldap_3.2.0.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-ldap_3.2.0.bb b/recipes-devtools/python/python-ldap_3.2.0.bb
index af8961e..8e43dee 100644
--- a/recipes-devtools/python/python-ldap_3.2.0.bb
+++ b/recipes-devtools/python/python-ldap_3.2.0.bb
@@ -23,9 +23,15 @@ do_configure_prepend() {
sed -i -e 's:^include_dirs =.*:include_dirs = =/usr/include/sasl/:' setup.cfg
}
+
RDEPENDS_${PN} = " \
${PYTHON_PN}-pprint \
${PYTHON_PN}-threading \
${PYTHON_PN}-pyasn1 \
${PYTHON_PN}-pyasn1-modules \
"
+
+python() {
+ if 'networking-layer' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires networking-layer to be present to provide cyrus-sasl.')
+}