aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-devtools/python/python-jinja2_2.7.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-jinja2_2.7.3.bb b/recipes-devtools/python/python-jinja2_2.7.3.bb
new file mode 100644
index 0000000..e66077a
--- /dev/null
+++ b/recipes-devtools/python/python-jinja2_2.7.3.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
+HOMEPAGE = "https://pypi.python.org/pypi/Jinja2"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=20c831f91dd3bd486020f672ba2be386"
+
+PR = "r0"
+SRCNAME = "Jinja2"
+
+SRC_URI = "https://pypi.python.org/packages/source/J/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "b9dffd2f3b43d673802fe857c8445b1a"
+SRC_URI[sha256sum] = "2e24ac5d004db5714976a04ac0e80c6df6e47e98c354cb2c0d82f8879d4f8fdb"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-io python-pickle python-crypt python-math python-netclient python-re python-textutils python-lang python-pprint python-shell python-markupsafe"