aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-06-13 11:25:33 +0800
committerKhem Raj <raj.khem@gmail.com>2019-06-15 16:45:32 -0700
commitda826a9eba6bba6996908beef8fd648b896ee1b7 (patch)
treedc66240f037bfe77c6f3fe153e63549f39382b4c /recipes-extended
parent34bb06148ea6b7c4da3a70e954a08a7ee45852b6 (diff)
downloadmeta-python2-da826a9eba6bba6996908beef8fd648b896ee1b7.tar.gz
python-pywbem: solved the conflict with python3-pywbem
-Use update-alternatives class to resolve conflicts with python3-pywbem. (From meta-openembedded commit: cdc746763189818b16c6eec35375a162359d4d27) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/pywbem/python-pywbem_0.11.0.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/recipes-extended/pywbem/python-pywbem_0.11.0.bb b/recipes-extended/pywbem/python-pywbem_0.11.0.bb
index 7410749..a699f1c 100644
--- a/recipes-extended/pywbem/python-pywbem_0.11.0.bb
+++ b/recipes-extended/pywbem/python-pywbem_0.11.0.bb
@@ -1,5 +1,5 @@
require python-pywbem.inc
-inherit setuptools
+inherit setuptools update-alternatives
DEPENDS += " \
${PYTHON_PN}-m2crypto-native \
@@ -11,3 +11,10 @@ RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-m2crypto \
${PYTHON_PN}-subprocess \
"
+
+ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
+ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
+ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
+ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
+
+ALTERNATIVE_PRIORITY = "30"