aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-03 15:04:17 -0500
committerKhem Raj <raj.khem@gmail.com>2018-06-22 10:52:33 -0700
commit94698c6ebf1b129004ace91ed3fe31b6ff5f6cc7 (patch)
tree54432a4cc40e10efd550999ed0e4ae73031a1734 /recipes-extended
parent0f83105aeeb36376533cf9ecf8af418a80eee7ba (diff)
downloadmeta-python2-94698c6ebf1b129004ace91ed3fe31b6ff5f6cc7.tar.gz
python-pywbem: update to version 0.11.0 and add a python3 recipe
(From meta-openembedded commit: 7516e8453a6eaac6cec7ac6251418fb047bccc8f) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/pywbem/python-pywbem.inc (renamed from recipes-extended/pywbem/pywbem_0.8.0.bb)36
-rw-r--r--recipes-extended/pywbem/python-pywbem_0.11.0.bb13
2 files changed, 37 insertions, 12 deletions
diff --git a/recipes-extended/pywbem/pywbem_0.8.0.bb b/recipes-extended/pywbem/python-pywbem.inc
index 7f1986e..5151c33 100644
--- a/recipes-extended/pywbem/pywbem_0.8.0.bb
+++ b/recipes-extended/pywbem/python-pywbem.inc
@@ -12,25 +12,37 @@ at http://www.dmtf.org/standards/wbem. \
\
It also provides a Python provider interface, and is the fastest and easiest \
way to write providers on the planet."
-HOMEPAGE = "http://pywbem.sf.net/"
-LICENSE = "LGPLv2"
+HOMEPAGE = "http://pywbem.github.io"
+LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://pywbem/LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
-SECTION = "Development/Libraries"
-DEPENDS = "python-m2crypto-native python-typing-native"
-SRC_URI = "http://jaist.dl.sourceforge.net/project/${BPN}/${BPN}/${BP}/${BP}-dev.r704.zip"
-SRC_URI[md5sum] = "84072451dcdd1aa9ee82363848faf7ad"
-SRC_URI[sha256sum] = "898035866d3cc741bbcd62c4ac26e633ad07b7c11d89db2472b9f923f3fd3ed8"
+SRC_URI[md5sum] = "1465dfa92e4cbe558c773838b9b00711"
+SRC_URI[sha256sum] = "2a05f2c1a6ab4b08560a6da55fdaabd0f52f4d1e6df6e288b9ed927bf5c289ed"
-S = "${WORKDIR}/${BP}-dev"
+inherit pypi
-inherit setuptools python-dir
+DEPENDS += " \
+ ${PYTHON_PN}-ply-native \
+ ${PYTHON_PN}-pyyaml-native \
+ ${PYTHON_PN}-six-native \
+"
do_install_append() {
mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli
- mv ${D}${bindir}/mof_compiler.py ${D}${bindir}/mofcomp
- rm ${D}${libdir}/python2.7/site-packages/${BPN}/wbemcli.py*
- rm ${D}${libdir}/python2.7/site-packages/${BPN}/mof_compiler.py*
+ rm -f ${D}${bindir}/*.bat
}
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
+ ${PYTHON_PN}-xml \
+"
+
BBCLASSEXTEND = "native"
diff --git a/recipes-extended/pywbem/python-pywbem_0.11.0.bb b/recipes-extended/pywbem/python-pywbem_0.11.0.bb
new file mode 100644
index 0000000..7410749
--- /dev/null
+++ b/recipes-extended/pywbem/python-pywbem_0.11.0.bb
@@ -0,0 +1,13 @@
+require python-pywbem.inc
+inherit setuptools
+
+DEPENDS += " \
+ ${PYTHON_PN}-m2crypto-native \
+ ${PYTHON_PN}-typing-native \
+"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-argparse \
+ ${PYTHON_PN}-m2crypto \
+ ${PYTHON_PN}-subprocess \
+"