aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-05 14:00:04 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-13 11:08:46 +0200
commitab7e70e9678560eb7b80338103af7a809509b770 (patch)
tree1ebde42e64fcbc13d7f49c55c0860bf2f9d0e2a6 /recipes-extended
parente47e58e78293cfd52031ef311f8618b7a94fcd38 (diff)
downloadmeta-python2-ab7e70e9678560eb7b80338103af7a809509b770.tar.gz
pywbem: Requires python-m2crypto-native (and others) from meta-python
Move pywbem to the meta-python layer to avoid missing requirements. (From meta-openembedded commit: 21fb078ce1651de0fb2f7876e6d8e5e3de728a95) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/pywbem/pywbem_0.8.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-extended/pywbem/pywbem_0.8.0.bb b/recipes-extended/pywbem/pywbem_0.8.0.bb
new file mode 100644
index 0000000..7f1986e
--- /dev/null
+++ b/recipes-extended/pywbem/pywbem_0.8.0.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Python WBEM Client and Provider Interface"
+DESCRIPTION = "\
+A Python library for making CIM (Common Information Model) operations over \
+HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \
+WBEM client should be easy to use and not necessarily require a large amount \
+of programming knowledge. It is suitable for a large range of tasks from \
+simply poking around to writing web and GUI applications. \
+\
+WBEM, or Web Based Enterprise Management is a manageability protocol, like \
+SNMP, standardised by the Distributed Management Task Force (DMTF) available \
+at http://www.dmtf.org/standards/wbem. \
+\
+It also provides a Python provider interface, and is the fastest and easiest \
+way to write providers on the planet."
+HOMEPAGE = "http://pywbem.sf.net/"
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://pywbem/LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
+SECTION = "Development/Libraries"
+DEPENDS = "python-m2crypto-native python-typing-native"
+SRC_URI = "http://jaist.dl.sourceforge.net/project/${BPN}/${BPN}/${BP}/${BP}-dev.r704.zip"
+SRC_URI[md5sum] = "84072451dcdd1aa9ee82363848faf7ad"
+SRC_URI[sha256sum] = "898035866d3cc741bbcd62c4ac26e633ad07b7c11d89db2472b9f923f3fd3ed8"
+
+S = "${WORKDIR}/${BP}-dev"
+
+inherit setuptools python-dir
+
+do_install_append() {
+ mv ${D}${bindir}/wbemcli.py ${D}${bindir}/pywbemcli
+ mv ${D}${bindir}/mof_compiler.py ${D}${bindir}/mofcomp
+
+ rm ${D}${libdir}/python2.7/site-packages/${BPN}/wbemcli.py*
+ rm ${D}${libdir}/python2.7/site-packages/${BPN}/mof_compiler.py*
+}
+
+BBCLASSEXTEND = "native"