aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-02 19:04:16 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-13 11:19:11 +0100
commit84cb11a3a7a669665c3f31ee893748dda733a7f6 (patch)
treef1c3d45dbe2828531af09c2fd9eb92b3fb1b9ad1 /recipes-extended
parent8743938e4750b1b4a40f1908b276a567beafd905 (diff)
downloadmeta-python2-84cb11a3a7a669665c3f31ee893748dda733a7f6.tar.gz
python-cson: Add recipe
(From meta-openembedded commit: c0c8f946c1354a6be7685a14cb34e940ebd15af5) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/python-cson/python-cson_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-extended/python-cson/python-cson_git.bb b/recipes-extended/python-cson/python-cson_git.bb
new file mode 100644
index 0000000..efb338c
--- /dev/null
+++ b/recipes-extended/python-cson/python-cson_git.bb
@@ -0,0 +1,21 @@
+# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Python library for CSON (schema-compressed JSON)"
+HOMEPAGE = "https://github.com/gt3389b/python-cson/"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7709d2635e63ab96973055a23c2a4cac"
+
+SRCREV = "f3f2898c44bb16b951d3e9f2fbf6d1c4158edda2"
+SRC_URI = "git://github.com/gt3389b/python-cson.git"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS_${PN}_class-native = ""
+DEPENDS_append_class-native = " python-native "
+
+inherit setuptools
+
+BBCLASSEXTEND = "native"
+