aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-03-12 15:44:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2021-03-17 11:48:07 +0100
commit10c65fc18998d302f34634ffceaf31ab335056dd (patch)
treec24af92cd55cc8f85c0c4c70f82e65ad66df9407 /recipes-extended
parent044015255944fd8db139caec8981f2957f8e2604 (diff)
downloadmeta-python2-10c65fc18998d302f34634ffceaf31ab335056dd.tar.gz
recipes: add conditional PNBLACKLIST in all recipes except python-native
* python-native is an exception because there is still e.g. chromium depending on _native_ python and a lot of people use it in some form, once https://bugs.chromium.org/p/chromium/issues/detail?id=942720 is resolved in stable chromium release the same will be set in python-native * https://www.python.org/doc/sunset-python-2/ * https://python3statement.org/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/python-cson/python-cson_git.bb2
-rw-r--r--recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb4
-rw-r--r--recipes-extended/python-pyparted/python-pyparted_git.bb2
-rw-r--r--recipes-extended/pywbem/python-pywbem_0.15.0.bb2
4 files changed, 10 insertions, 0 deletions
diff --git a/recipes-extended/python-cson/python-cson_git.bb b/recipes-extended/python-cson/python-cson_git.bb
index efb338c..7bc86c0 100644
--- a/recipes-extended/python-cson/python-cson_git.bb
+++ b/recipes-extended/python-cson/python-cson_git.bb
@@ -19,3 +19,5 @@ inherit setuptools
BBCLASSEXTEND = "native"
+
+PNBLACKLIST[python-cson] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb b/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb
index 422f0db..535c6da 100644
--- a/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb
+++ b/recipes-extended/python-pyephem/python-pyephem_3.7.7.0.bb
@@ -15,3 +15,7 @@ RDEPENDS_${PN} += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-math \
"
+
+
+
+PNBLACKLIST[python-pyephem] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-extended/python-pyparted/python-pyparted_git.bb b/recipes-extended/python-pyparted/python-pyparted_git.bb
index 1f36924..485bf5c 100644
--- a/recipes-extended/python-pyparted/python-pyparted_git.bb
+++ b/recipes-extended/python-pyparted/python-pyparted_git.bb
@@ -33,3 +33,5 @@ RDEPENDS_${PN} += "python-stringold python-codecs python-math python-subprocess"
RDEPENDS_${PN}_class-native = ""
BBCLASSEXTEND = "native"
+
+PNBLACKLIST[python-pyparted] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"
diff --git a/recipes-extended/pywbem/python-pywbem_0.15.0.bb b/recipes-extended/pywbem/python-pywbem_0.15.0.bb
index 2b1e930..eee8416 100644
--- a/recipes-extended/pywbem/python-pywbem_0.15.0.bb
+++ b/recipes-extended/pywbem/python-pywbem_0.15.0.bb
@@ -66,3 +66,5 @@ ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
ALTERNATIVE_PRIORITY = "30"
BBCLASSEXTEND = "native"
+
+PNBLACKLIST[python-pywbem] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"