aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:34 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-26 17:28:12 -0800
commitfff8a16bb1829e18e058b40bc7e84ffdaa5b0e91 (patch)
tree711f93c3fb51bca0711d752afc3586e1719717b0 /recipes-devtools
parentab9de59bda3c260be9345102d21021af057aabbd (diff)
downloadmeta-python2-fff8a16bb1829e18e058b40bc7e84ffdaa5b0e91.tar.gz
Remove deprecated python3-lang from the RDEPENDS
The python3-lang package was removed as part of the migration to the json manifest file. The functionality is now part of core (From meta-openembedded commit: ef52e998043384350b558dd4f75fdb0400e18a98) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-jinja2.inc2
-rw-r--r--recipes-devtools/python/python-jinja2_2.10.bb2
-rw-r--r--recipes-devtools/python/python-jsonschema.inc1
-rw-r--r--recipes-devtools/python/python-jsonschema_2.6.0.bb1
-rw-r--r--recipes-devtools/python/python-pyasn1.inc1
-rw-r--r--recipes-devtools/python/python-pyasn1_0.4.2.bb4
6 files changed, 7 insertions, 4 deletions
diff --git a/recipes-devtools/python/python-jinja2.inc b/recipes-devtools/python/python-jinja2.inc
index 72562fb..510765b 100644
--- a/recipes-devtools/python/python-jinja2.inc
+++ b/recipes-devtools/python/python-jinja2.inc
@@ -9,7 +9,7 @@ SRC_URI[sha256sum] = "f84be1bb0040caca4cea721fcbbbbd61f9be9464ca236387158b0feea0
RDEPENDS_${PN} += "${PYTHON_PN}-io ${PYTHON_PN}-pickle ${PYTHON_PN}-crypt \
${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-textutils \
- ${PYTHON_PN}-lang ${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \
+ ${PYTHON_PN}-pprint ${PYTHON_PN}-shell ${PYTHON_PN}-markupsafe \
${PYTHON_PN}-json ${PYTHON_PN}-threading ${PYTHON_PN}-numbers"
CLEANBROKEN = "1"
diff --git a/recipes-devtools/python/python-jinja2_2.10.bb b/recipes-devtools/python/python-jinja2_2.10.bb
index 19b2bfa..0607521 100644
--- a/recipes-devtools/python/python-jinja2_2.10.bb
+++ b/recipes-devtools/python/python-jinja2_2.10.bb
@@ -1,4 +1,4 @@
inherit pypi setuptools
require python-jinja2.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-re"
+RDEPENDS_${PN} += "${PYTHON_PN}-lang ${PYTHON_PN}-re"
diff --git a/recipes-devtools/python/python-jsonschema.inc b/recipes-devtools/python/python-jsonschema.inc
index b602b27..748ef6e 100644
--- a/recipes-devtools/python/python-jsonschema.inc
+++ b/recipes-devtools/python/python-jsonschema.inc
@@ -11,7 +11,6 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-core \
${PYTHON_PN}-io \
${PYTHON_PN}-json \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-netclient \
${PYTHON_PN}-numbers \
${PYTHON_PN}-pkgutil \
diff --git a/recipes-devtools/python/python-jsonschema_2.6.0.bb b/recipes-devtools/python/python-jsonschema_2.6.0.bb
index 55cbb20..c118f2d 100644
--- a/recipes-devtools/python/python-jsonschema_2.6.0.bb
+++ b/recipes-devtools/python/python-jsonschema_2.6.0.bb
@@ -5,5 +5,6 @@ RDEPENDS_${PN} += " \
${PYTHON_PN}-argparse \
${PYTHON_PN}-contextlib \
${PYTHON_PN}-functools32 \
+ ${PYTHON_PN}-lang \
${PYTHON_PN}-re \
"
diff --git a/recipes-devtools/python/python-pyasn1.inc b/recipes-devtools/python/python-pyasn1.inc
index 2539101..f3c32e0 100644
--- a/recipes-devtools/python/python-pyasn1.inc
+++ b/recipes-devtools/python/python-pyasn1.inc
@@ -8,7 +8,6 @@ SRC_URI[sha256sum] = "d258b0a71994f7770599835249cece1caef3c70def868c4915e6e5ca49
RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-codecs \
- ${PYTHON_PN}-lang \
${PYTHON_PN}-logging \
${PYTHON_PN}-math \
${PYTHON_PN}-shell \
diff --git a/recipes-devtools/python/python-pyasn1_0.4.2.bb b/recipes-devtools/python/python-pyasn1_0.4.2.bb
index 4461918..a13c74d 100644
--- a/recipes-devtools/python/python-pyasn1_0.4.2.bb
+++ b/recipes-devtools/python/python-pyasn1_0.4.2.bb
@@ -1,2 +1,6 @@
inherit pypi setuptools
require python-pyasn1.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-lang \
+"