aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-10 17:08:25 +0100
committerKhem Raj <raj.khem@gmail.com>2018-07-12 07:19:43 -0700
commitf95ec3cd6d33e8abe9d0734155f1eab6b7cc93f7 (patch)
tree488238c6be602eff6e6f7c5afbf7ac41c0d62d94 /recipes-devtools
parent4c8910878aab664a8cc6d6179210bc4763039c58 (diff)
downloadmeta-python2-f95ec3cd6d33e8abe9d0734155f1eab6b7cc93f7.tar.gz
python-stevedore: add Py2 and Py3 recipes for stevedore
Based on a recipe from meta-openstack, but with the rmargparse class removed (which doesn't appear to be needed anymore) and Python 3 support added. (From meta-openembedded commit: 9f292d50183baa1951dc2ff3b9b691852b89eadb) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-stevedore.inc13
-rw-r--r--recipes-devtools/python/python-stevedore_1.28.0.bb2
2 files changed, 15 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-stevedore.inc b/recipes-devtools/python/python-stevedore.inc
new file mode 100644
index 0000000..b23fb4c
--- /dev/null
+++ b/recipes-devtools/python/python-stevedore.inc
@@ -0,0 +1,13 @@
+DESCRIPTION = "Manage dynamic plugins for Python applications"
+HOMEPAGE = "https://github.com/dreamhost/stevedore"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "b736a71431a2ff5831bbff4a6ccec0c1"
+SRC_URI[sha256sum] = "f1c7518e7b160336040fee272174f1f7b29a46febb3632502a8f2055f973d60b"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pbr ${PYTHON_PN}-six"
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-stevedore_1.28.0.bb b/recipes-devtools/python/python-stevedore_1.28.0.bb
new file mode 100644
index 0000000..70a00c1
--- /dev/null
+++ b/recipes-devtools/python/python-stevedore_1.28.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-stevedore.inc