aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-07-31 12:15:25 +0000
committerKhem Raj <raj.khem@gmail.com>2018-08-02 11:23:02 -0700
commitda790af2f9c49082d42701c7c82a523c0122f7b5 (patch)
tree0c09c44bcd7a910518990748f571f538aa45b84c /recipes-devtools
parentac7c41248e72d5b28d3c1d15687b1d37f3e50d4a (diff)
downloadmeta-python2-da790af2f9c49082d42701c7c82a523c0122f7b5.tar.gz
python-{m2crypto, protobuf, slip-dbus}, lio-utils: add CLEANBROKEN
* these are failing after distutils started calling clean in: http://git.openembedded.org/openembedded-core/commit/?id=57414f4a1c549e6faaa110e6e95ff601b05b7361 http://git.openembedded.org/openembedded-core/commit/?id=9d556092fcc6f04c487afd126d52935bac133165 (From meta-openembedded commit: 19aeaf028f6819e5fa705593d4bcdbf0b98143e0) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-m2crypto_0.26.4.bb4
-rw-r--r--recipes-devtools/python/python-protobuf_3.6.0.bb3
-rw-r--r--recipes-devtools/python/python-slip-dbus_0.6.1.bb4
3 files changed, 11 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-m2crypto_0.26.4.bb b/recipes-devtools/python/python-m2crypto_0.26.4.bb
index 272c76c..899a361 100644
--- a/recipes-devtools/python/python-m2crypto_0.26.4.bb
+++ b/recipes-devtools/python/python-m2crypto_0.26.4.bb
@@ -48,3 +48,7 @@ do_compile_prepend() {
}
BBCLASSEXTEND = "native"
+
+# http://errors.yoctoproject.org/Errors/Details/184714/
+# SWIG/_m2crypto.i:10: Error: Unable to find 'gcc_macros.h'
+CLEANBROKEN = "1"
diff --git a/recipes-devtools/python/python-protobuf_3.6.0.bb b/recipes-devtools/python/python-protobuf_3.6.0.bb
index dc0823f..dddc9bb 100644
--- a/recipes-devtools/python/python-protobuf_3.6.0.bb
+++ b/recipes-devtools/python/python-protobuf_3.6.0.bb
@@ -1,3 +1,6 @@
inherit setuptools
require python-protobuf.inc
+# http://errors.yoctoproject.org/Errors/Details/184715/
+# Can't find required file: ../src/google/protobuf/descriptor.proto
+CLEANBROKEN = "1"
diff --git a/recipes-devtools/python/python-slip-dbus_0.6.1.bb b/recipes-devtools/python/python-slip-dbus_0.6.1.bb
index 8081416..dc587e7 100644
--- a/recipes-devtools/python/python-slip-dbus_0.6.1.bb
+++ b/recipes-devtools/python/python-slip-dbus_0.6.1.bb
@@ -25,3 +25,7 @@ SRC_URI[sha256sum] = "bc897f1ab6f5b4989f85548799aaeb84fde67bbba18e40341bfe1d7885
do_compile_prepend() {
sed -e 's/@VERSION@/${PV}/g' setup.py.in > setup.py
}
+
+# http://errors.yoctoproject.org/Errors/Details/184713/
+# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
+CLEANBROKEN = "1"