aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2018-08-29 13:14:54 +0300
committerKhem Raj <raj.khem@gmail.com>2018-08-29 18:18:14 -0700
commit5989a45934f594e545077785992743432867bd13 (patch)
tree5fd524eb907b2a947306b4aa141bb09737c4c7cf /recipes-devtools
parentbe214d252e5e77f0233533497d9af708ea1a66e0 (diff)
downloadmeta-python2-5989a45934f594e545077785992743432867bd13.tar.gz
python3-pytest-tempdir: add recipe
(From meta-openembedded commit: 2b5fb4f8178cc685dab6719eb02f2e43b80beec0) Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-pytest-tempdir.inc10
-rw-r--r--recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb11
2 files changed, 12 insertions, 9 deletions
diff --git a/recipes-devtools/python/python-pytest-tempdir.inc b/recipes-devtools/python/python-pytest-tempdir.inc
new file mode 100644
index 0000000..196f6d6
--- /dev/null
+++ b/recipes-devtools/python/python-pytest-tempdir.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Adds support for a predictable and repeatable temporary directory."
+HOMEPAGE = "https://github.com/saltstack/pytest-tempdir"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=8751a9cf4a70be4f02697a9b89e686ce"
+
+SRC_URI[md5sum] = "f87f2583f5f8aaca7203d57ada3948b5"
+SRC_URI[sha256sum] = "65ff815966ea6dfc07ca1b43747c9888a6d883971170e67b16290f9f50d434ea"
+
+inherit pypi
diff --git a/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb b/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
index 74030dc..8a9b83e 100644
--- a/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
+++ b/recipes-devtools/python/python-pytest-tempdir_2016.8.20.bb
@@ -1,13 +1,6 @@
-DESCRIPTION = "Adds support for a predictable and repeatable temporary directory."
-HOMEPAGE = "https://github.com/saltstack/pytest-tempdir"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=8751a9cf4a70be4f02697a9b89e686ce"
+require python-pytest-tempdir.inc
-SRC_URI[md5sum] = "f87f2583f5f8aaca7203d57ada3948b5"
-SRC_URI[sha256sum] = "65ff815966ea6dfc07ca1b43747c9888a6d883971170e67b16290f9f50d434ea"
-
-inherit pypi setuptools
+inherit setuptools
RDEPENDS_${PN} += " \
python-pytest \