aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-07-10 16:20:12 +0100
committerKhem Raj <raj.khem@gmail.com>2018-07-12 07:19:43 -0700
commit4c8910878aab664a8cc6d6179210bc4763039c58 (patch)
treeeba8363fd924cbc0f6a4b03f1ab32d46b622c531 /recipes-devtools
parentcf99a9b77fe3d11d23f96135a7aaf62e61cb2cb8 (diff)
downloadmeta-python2-4c8910878aab664a8cc6d6179210bc4763039c58.tar.gz
python-pbr: add python3-pbr variant
(From meta-openembedded commit: 63299b239116a70ce4b09dc925c5eaebb63a3052) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-pbr.inc14
-rw-r--r--recipes-devtools/python/python-pbr_3.1.1.bb18
2 files changed, 16 insertions, 16 deletions
diff --git a/recipes-devtools/python/python-pbr.inc b/recipes-devtools/python/python-pbr.inc
new file mode 100644
index 0000000..d8847f6
--- /dev/null
+++ b/recipes-devtools/python/python-pbr.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "Python Build Reasonableness: PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
+HOMEPAGE = "https://pypi.python.org/pypi/pbr"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
+
+SRC_URI[md5sum] = "4e82c2e07af544c56a5b71c801525b00"
+SRC_URI[sha256sum] = "05f61c71aaefc02d8e37c0a3eeb9815ff526ea28b3b76324769e6158d7f95be1"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pip"
+
+BBCLASSEXTEND = "native"
diff --git a/recipes-devtools/python/python-pbr_3.1.1.bb b/recipes-devtools/python/python-pbr_3.1.1.bb
index bdff867..8f7f924 100644
--- a/recipes-devtools/python/python-pbr_3.1.1.bb
+++ b/recipes-devtools/python/python-pbr_3.1.1.bb
@@ -1,16 +1,2 @@
-DESCRIPTION = "Python Build Reasonableness: PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
-HOMEPAGE = "https://pypi.python.org/pypi/pbr"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
-
-SRC_URI[md5sum] = "4e82c2e07af544c56a5b71c801525b00"
-SRC_URI[sha256sum] = "05f61c71aaefc02d8e37c0a3eeb9815ff526ea28b3b76324769e6158d7f95be1"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN}_class-target += " \
- python-pip \
- "
-
-BBCLASSEXTEND = "native"
+inherit setuptools
+require python-pbr.inc