aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:56:54 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:25 +0200
commita425f0faf8ecbc4a508572ed3360d30ac927208a (patch)
tree8e1efea57084ec9a92f16336933636164a678427 /recipes-devtools
parent39d738fcd6acd5b00b1f31be3a2b38e34f8b69e9 (diff)
downloadmeta-python2-a425f0faf8ecbc4a508572ed3360d30ac927208a.tar.gz
Remove unnecessary exports of HOST_SYS and BUILD_SYS in python-based recipes
They are no longer required to build python software. (From meta-openembedded commit: f9ce43cdf6639acaa59d6144aabee798970ca3b6) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-matplotlib_1.1.0.bb3
-rw-r--r--recipes-devtools/python/python-six.inc1
-rw-r--r--recipes-devtools/python/python-vcversioner_2.14.0.0.bb1
3 files changed, 0 insertions, 5 deletions
diff --git a/recipes-devtools/python/python-matplotlib_1.1.0.bb b/recipes-devtools/python/python-matplotlib_1.1.0.bb
index 69f71c7..133e66d 100644
--- a/recipes-devtools/python/python-matplotlib_1.1.0.bb
+++ b/recipes-devtools/python/python-matplotlib_1.1.0.bb
@@ -19,15 +19,12 @@ EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
inherit distutils
do_compile_prepend() {
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
${STAGING_BINDIR_NATIVE}/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
true
}
# need to export these variables for python-config to work
export PYTHONPATH
-export BUILD_SYS
-export HOST_SYS
export STAGING_INCDIR
export STAGING_LIBDIR
diff --git a/recipes-devtools/python/python-six.inc b/recipes-devtools/python/python-six.inc
index 408c60e..625cbad 100644
--- a/recipes-devtools/python/python-six.inc
+++ b/recipes-devtools/python/python-six.inc
@@ -6,7 +6,6 @@ SRC_URI[md5sum] = "34eed507548117b2ab523ab14b2f8b55"
SRC_URI[sha256sum] = "105f8d68616f8248e24bf0e9372ef04d3cc10104f1980f54d57b2ce73a5ad56a"
do_compile_append() {
- export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
${PYTHON} setup.py -q bdist_egg --dist-dir ./
}
do_install_append() {
diff --git a/recipes-devtools/python/python-vcversioner_2.14.0.0.bb b/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
index e87e50f..0df18f5 100644
--- a/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
+++ b/recipes-devtools/python/python-vcversioner_2.14.0.0.bb
@@ -10,7 +10,6 @@ SRC_URI[sha256sum] = "acd43686e92e6c8bbeb4f2eef54408567a7adea9692fa72d591eec5357
inherit pypi setuptools
do_compile_append() {
- export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
${PYTHON} setup.py -q bdist_egg --dist-dir ./
}