aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-18 10:03:54 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-20 14:51:57 +0100
commitf2581732da78b06bdb9325b554f3a5c7fa5030a9 (patch)
tree84be2206422cdbb39516fa96ca436b8d56f245d7 /recipes-devtools
parenta42afd0b34aa811f6bad6f9b9969900825c8339e (diff)
downloadmeta-python2-f2581732da78b06bdb9325b554f3a5c7fa5030a9.tar.gz
python-gdata: RDepend on python-xml instead of python-elementtree
* python-elementtree was folded to python-xml by this oe-core commit: commit 5f7206eba3953b7f29148ecfb791995773ee5fc7 Author: Ross Burton <ross.burton@intel.com> Date: Wed Feb 10 14:04:04 2016 +0000 python: merge python-elementtree into python-xml python-xml depends on python-elementtree as the latter just contains a C library used by the former. However there's no point to this split apart from increasing the number of packages, so merge -elementtree into python-xml. * this is just band-aid for missing RPROVIDEs in that oe-core commit and be aware that upgrade-path on target is still broken (no RREPLACES/RCONFLICTS), so you'll need "upgrade" from python-elementtree manually on target. * fixes: ERROR: Nothing RPROVIDES 'python-elementtree' (but /home/jenkins/oe/world/shr-core/meta-openembedded/meta-python/recipes-devtools/python/python-gdata_1.2.4.bb RDEPENDS on or otherwise requires it) NOTE: Runtime target 'python-elementtree' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python-elementtree'] NOTE: Runtime target 'python-gdata-dev' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python-gdata-dev', 'python-elementtree'] NOTE: Runtime target 'python-gdata' is unbuildable, removing... Missing or unbuildable dependency chain was: ['python-gdata', 'python-elementtree'] Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-gdata_1.2.4.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-gdata_1.2.4.bb b/recipes-devtools/python/python-gdata_1.2.4.bb
index ea60277..2205584 100644
--- a/recipes-devtools/python/python-gdata_1.2.4.bb
+++ b/recipes-devtools/python/python-gdata_1.2.4.bb
@@ -14,5 +14,4 @@ S = "${WORKDIR}/gdata.py-${PV}"
FILES_${PN} += "${datadir}"
-RDEPENDS_${PN} = "python-elementtree"
-
+RDEPENDS_${PN} = "python-xml"