aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorSven Ebenfeld <sven.ebenfeld@gmail.com>2016-01-22 23:36:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:51:16 +0100
commit8a6460964efafd36d700e874ab2024d23a361eb3 (patch)
treedb97b9f88bf1f32ad12cb12a77909fea694db2ed /recipes-devtools
parenta0f0d8efb8f91bfbe4a2aeb964c1b8f44f7bf773 (diff)
downloadmeta-python2-8a6460964efafd36d700e874ab2024d23a361eb3.tar.gz
python-requests: 2.7.0 -> 2.9.1 and add python3 recipe
(From meta-openembedded commit: 518234dbaabb57338166cbcaa8af163d9eb14ef6) Signed-off-by: Sven Ebenfeld <sven.ebenfeld@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-requests.inc9
-rw-r--r--recipes-devtools/python/python-requests_2.7.0.bb18
-rw-r--r--recipes-devtools/python/python-requests_2.9.1.bb4
3 files changed, 13 insertions, 18 deletions
diff --git a/recipes-devtools/python/python-requests.inc b/recipes-devtools/python/python-requests.inc
new file mode 100644
index 0000000..ebce253
--- /dev/null
+++ b/recipes-devtools/python/python-requests.inc
@@ -0,0 +1,9 @@
+DESCRIPTION = "Python HTTP for Humans."
+HOMEPAGE = "http://python-requests.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=58c7e163c9f8ee037246da101c6afd1e"
+
+SRC_URI[md5sum] = "0b7f480d19012ec52bab78292efd976d"
+SRC_URI[sha256sum] = "c577815dd00f1394203fc44eb979724b098f88264a9ef898ee45b8e5e9cf587f"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-email ${PYTHON_PN}-json ${PYTHON_PN}-netserver"
diff --git a/recipes-devtools/python/python-requests_2.7.0.bb b/recipes-devtools/python/python-requests_2.7.0.bb
deleted file mode 100644
index ac47202..0000000
--- a/recipes-devtools/python/python-requests_2.7.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "Python HTTP for Humans."
-HOMEPAGE = "http://python-requests.org"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=58c7e163c9f8ee037246da101c6afd1e"
-
-SRCNAME = "requests"
-
-SRC_URI = "http://pypi.python.org/packages/source/r/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
-
-SRC_URI[md5sum] = "29b173fd5fa572ec0764d1fd7b527260"
-SRC_URI[sha256sum] = "398a3db6d61899d25fd4a06c6ca12051b0ce171d705decd7ed5511517b4bb93d"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
-
-RDEPENDS_${PN} = "python-email python-json python-netserver python-zlib"
diff --git a/recipes-devtools/python/python-requests_2.9.1.bb b/recipes-devtools/python/python-requests_2.9.1.bb
new file mode 100644
index 0000000..acc8c16
--- /dev/null
+++ b/recipes-devtools/python/python-requests_2.9.1.bb
@@ -0,0 +1,4 @@
+inherit pypi
+require python-requests.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-zlib" \ No newline at end of file