aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2016-01-04 13:12:37 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-27 12:43:57 +0100
commit162d0561c2676d0c258d9fb3140f9dc50a1fe181 (patch)
tree3349809a235a0f5ef8167ddaf05a0c746a06ee21 /recipes-devtools
parent0b596e9d906233542e4754cc53307d3de4edc8b6 (diff)
downloadmeta-python2-162d0561c2676d0c258d9fb3140f9dc50a1fe181.tar.gz
python-six: Error fix for recipes depend on python-six
If you bitbake recipes which depends on python-six such as python-cryptography. And also your network is not very well. Error will occur as following: Download error on https://pypi.python.org/simple/six/: [Errno -5] No address associated with hostname -- Some packages may not be found! Couldn't find index page for 'six' (maybe misspelled?) No local packages or download links found for six So add do_compile_append() to fix it. (From meta-openembedded commit: 6b4cee97597c0587cc83b787f036dbfa181915f2) Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-six_1.9.0.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-six_1.9.0.bb b/recipes-devtools/python/python-six_1.9.0.bb
index aa96dc9..c6575f3 100644
--- a/recipes-devtools/python/python-six_1.9.0.bb
+++ b/recipes-devtools/python/python-six_1.9.0.bb
@@ -6,3 +6,11 @@ SRC_URI[md5sum] = "476881ef4012262dfc8adc645ee786c4"
SRC_URI[sha256sum] = "e24052411fc4fbd1f672635537c3fc2330d9481b18c0317695b46259512c91d5"
inherit pypi
+
+do_compile_append() {
+ export BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS}
+ ${PYTHON} setup.py -q bdist_egg --dist-dir ./
+}
+do_install_append() {
+ install -m 0644 ${S}/*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
+}