aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-01-11 18:00:59 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-27 12:36:30 +0100
commit0a31523d11b0f2b8a61bc04ba2fdd183c6f952e2 (patch)
tree0e1cfe3185d671ec2fbc3b0a2b0887b94d84eccb /recipes-devtools
parentb3d157c06c236d5731fc47580a28cd2f92507018 (diff)
downloadmeta-python2-0a31523d11b0f2b8a61bc04ba2fdd183c6f952e2.tar.gz
python-jsonpatch: add recipe for 1.12
(From meta-openembedded commit: 669f87ad16a9d93141cb21bae302272d731d3b82) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-jsonpatch_1.12.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-jsonpatch_1.12.bb b/recipes-devtools/python/python-jsonpatch_1.12.bb
new file mode 100644
index 0000000..504bb99
--- /dev/null
+++ b/recipes-devtools/python/python-jsonpatch_1.12.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
+
+SRCNAME = "jsonpatch"
+
+SRC_URI = " \
+ https://pypi.python.org/packages/source/j/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+"
+
+inherit setuptools
+
+SRC_URI[md5sum] = "76ae3183db5f2a8f85dd7705e9b6f278"
+SRC_URI[sha256sum] = "2e1eb457f9c8dd5dae837ca93c0fe5bd2522c9d44b9b380fb1aab2ab4dec04b1"
+
+RDEPENDS_${PN} += "python-re python-json python-jsonpointer"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+