aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2017-06-01 09:42:48 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-12 06:56:24 +0200
commitc15be78e232469963bd94506464d4e443c2321ec (patch)
treea790b1e30c3085a053104b19581eed8f157fe982 /recipes-devtools
parent6cbe69a57bba3d0a07733ea41a650d6ecae9f5a9 (diff)
downloadmeta-python2-c15be78e232469963bd94506464d4e443c2321ec.tar.gz
python-greenlet: Add support for python3
Extend recipe to support python3 as well (From meta-openembedded commit: f53d17a1a91409cf8aa7e986e70e945e44453ded) Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-greenlet.inc9
-rw-r--r--recipes-devtools/python/python-greenlet_0.4.12.bb12
2 files changed, 11 insertions, 10 deletions
diff --git a/recipes-devtools/python/python-greenlet.inc b/recipes-devtools/python/python-greenlet.inc
new file mode 100644
index 0000000..35820db
--- /dev/null
+++ b/recipes-devtools/python/python-greenlet.inc
@@ -0,0 +1,9 @@
+SUMMARY = "Python lightweight in-process concurrent programming"
+LICENSE = "MIT & PSF"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \
+ file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
+
+SRC_URI[md5sum] = "e8637647d58a26c4a1f51ca393e53c00"
+SRC_URI[sha256sum] = "e4c99c6010a5d153d481fdaf63b8a0782825c0721506d880403a3b9b82ae347e"
+
+inherit pypi
diff --git a/recipes-devtools/python/python-greenlet_0.4.12.bb b/recipes-devtools/python/python-greenlet_0.4.12.bb
index 4fc2c1d..c14976e 100644
--- a/recipes-devtools/python/python-greenlet_0.4.12.bb
+++ b/recipes-devtools/python/python-greenlet_0.4.12.bb
@@ -1,10 +1,2 @@
-SUMMARY = "Python lightweight in-process concurrent programming"
-LICENSE = "MIT & PSF"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=03143d7a1a9f5d8a0fee825f24ca9c36 \
- file://LICENSE.PSF;md5=c106931d9429eda0492617f037b8f69a"
-
-SRC_URI[md5sum] = "e8637647d58a26c4a1f51ca393e53c00"
-SRC_URI[sha256sum] = "e4c99c6010a5d153d481fdaf63b8a0782825c0721506d880403a3b9b82ae347e"
-
-inherit pypi distutils
-
+inherit distutils
+require python-greenlet.inc