aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-01-19 11:51:51 -0800
committerTim Orling <ticotimo@gmail.com>2020-01-19 17:53:57 -0800
commitd4fb0865b9e30515fb44db698f58b7ecca9f04af (patch)
tree0237356d9f5dbb55494a8392918c41ab7048a71b /recipes-devtools
parent96dba5d327e81a7554c8df9627dd4b8f7a6f08b1 (diff)
downloadmeta-python2-d4fb0865b9e30515fb44db698f58b7ecca9f04af.tar.gz
python-backports-functools-lru-cache: 1.5 -> 1.6.1
* Add run-time dependency on python-pkgutil * Install backports/functools_lru_cache.py License-Update: LICENSE file is now provided Upstream release notes: - v1.6.1 Publish release notes on readthedocs. - v1.6.0 Refresh package metadata. Use black for code style. Enroll with Tidelift. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb19
-rw-r--r--recipes-devtools/python/python-backports-functools-lru-cache_1.6.1.bb27
2 files changed, 27 insertions, 19 deletions
diff --git a/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb b/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb
deleted file mode 100644
index 11c1533..0000000
--- a/recipes-devtools/python/python-backports-functools-lru-cache_1.5.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "Backport of functools.lru_cache from Python 3.3"
-HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
-SECTION = "devel/python"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://setup.py;beginline=57;endline=57;md5=98fc3658e5970d26f6b2109808c766be"
-
-PYPI_PACKAGE = "backports.functools_lru_cache"
-
-SRC_URI[md5sum] = "20f53f54cd3f04b3346ce75a54959754"
-SRC_URI[sha256sum] = "9d98697f088eb1b0fa451391f91afb5e3ebde16bbdb272819fd091151fda4f1a"
-
-DEPENDS += "python-setuptools-scm-native"
-
-inherit setuptools pypi python-backports-init
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-pickle \
- ${PYTHON_PN}-threading \
- "
diff --git a/recipes-devtools/python/python-backports-functools-lru-cache_1.6.1.bb b/recipes-devtools/python/python-backports-functools-lru-cache_1.6.1.bb
new file mode 100644
index 0000000..8c40cf5
--- /dev/null
+++ b/recipes-devtools/python/python-backports-functools-lru-cache_1.6.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Backport of functools.lru_cache from Python 3.3"
+HOMEPAGE = "https://github.com/jaraco/backports.functools_lru_cache"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+
+PYPI_PACKAGE = "backports.functools_lru_cache"
+
+SRC_URI[md5sum] = "103000b21a8e683647e2ce41929f2a9d"
+SRC_URI[sha256sum] = "8fde5f188da2d593bd5bc0be98d9abc46c95bb8a9dde93429570192ee6cc2d4a"
+
+DEPENDS += "python-setuptools-scm-native"
+
+inherit setuptools pypi python-backports-init
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-threading \
+ "
+
+do_install() {
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}/backports
+ install ${B}/backports/functools_lru_cache.py ${D}${PYTHON_SITEPACKAGES_DIR}/backports/
+}
+
+FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/backports/functools_lru_cache.py"