aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2019-12-10 17:22:59 -0500
committerTim Orling <ticotimo@gmail.com>2020-01-19 09:40:45 -0800
commita556110b712a6a5cd04739787360d8d05f1d895f (patch)
tree760024ac6847f0f55b401ff44b9b423c34f332fa /recipes-devtools
parent8445797e30f2bd816b035fb34cb6aa41c548dd80 (diff)
downloadmeta-python2-a556110b712a6a5cd04739787360d8d05f1d895f.tar.gz
python-twisted: add missing RDEPENDS for conch
import twisted.conch.checkers outputs error messages like the following for multiple modules: |Python 3.7.4 (default, Oct 28 2019, 02:05:50) |[GCC 9.2.0] on linux |Type "help", "copyright", "credits" or "license" for more information. |>>> import twisted.conch.checkers | |Error message : |File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed |File "/usr/lib64/python3.7/site-packages/twisted/conch/checkers.py", line 32, in |<module> |from twisted.conch.ssh import keys |File "/usr/lib64/python3.7/site-packages/twisted/conch/ssh/keys.py", line 18, in |<module> |import bcrypt |No module named 'bcrypt' Add the missing RDEPENDS so that it works (bcrypt, cryptography, pyasn1, pickle). (From meta-openembedded commit: c3a3470b1ba3768e04e0a938870ad487bd848120) Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-twisted_19.10.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-twisted_19.10.0.bb b/recipes-devtools/python/python-twisted_19.10.0.bb
index 6b7e059..a8b6a49 100644
--- a/recipes-devtools/python/python-twisted_19.10.0.bb
+++ b/recipes-devtools/python/python-twisted_19.10.0.bb
@@ -60,7 +60,7 @@ RDEPENDS_${PN} = "\
RDEPENDS_${PN}-core = "${PYTHON_PN}-core ${PYTHON_PN}-zopeinterface ${PYTHON_PN}-incremental ${PYTHON_PN}-constantly ${PYTHON_PN}-hyperlink ${PYTHON_PN}-automat ${PYTHON_PN}-pyserial"
RDEPENDS_${PN}-test = "${PN}"
-RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols"
+RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols ${PYTHON_PN}-bcrypt ${PYTHON_PN}-cryptography ${PYTHON_PN}-pyasn1 ${PYTHON_PN}-pickle"
RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"
RDEPENDS_${PN}-names = "${PN}-core"
RDEPENDS_${PN}-news = "${PN}-core ${PN}-protocols"