aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-12-10 17:06:15 +0000
committerTim Orling <ticotimo@gmail.com>2020-01-18 22:20:30 -0800
commit65501feea58c75b6ca6ea454e0465e99266e08e4 (patch)
tree4b76bfe11848baa61a15a330f9fb4fe2b3409f2a /recipes-devtools
parentcee308baa652db4edf73c2c8ccaf547c8e3b18dc (diff)
downloadmeta-python2-65501feea58c75b6ca6ea454e0465e99266e08e4.tar.gz
python-m2crypto: don't use relative paths
(From meta-openembedded commit: 4f3e44d4ac9fd52e4be8b42d5b2cd14ffea3cd8d) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-m2crypto_0.30.1.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-devtools/python/python-m2crypto_0.30.1.bb b/recipes-devtools/python/python-m2crypto_0.30.1.bb
index 25b02d8..22bf56a 100644
--- a/recipes-devtools/python/python-m2crypto_0.30.1.bb
+++ b/recipes-devtools/python/python-m2crypto_0.30.1.bb
@@ -34,7 +34,7 @@ export SWIG_FEATURES
#
do_configure_prepend() {
${CPP} -dM - < /dev/null | grep -v '__\(STDC\|REGISTER_PREFIX\|GNUC\|STDC_HOSTED\)__' \
- | sed 's/^\(#define \([^ ]*\) .*\)$/#undef \2\n\1/' > SWIG/gcc_macros.h
+ | sed 's/^\(#define \([^ ]*\) .*\)$/#undef \2\n\1/' > ${S}/SWIG/gcc_macros.h
if [ "${SITEINFO_BITS}" = "64" ];then
bit="64"
@@ -44,11 +44,11 @@ do_configure_prepend() {
if [ -e ${STAGING_INCDIR}/openssl/opensslconf-${bit}.h ] ;then
for i in SWIG/_ec.i SWIG/_evp.i; do
- sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "$i"
+ sed -i -e "s/opensslconf.*\./opensslconf-${bit}\./" "${S}/$i"
done
elif [ -e ${STAGING_INCDIR}/openssl/opensslconf-n${bit}.h ] ;then
for i in SWIG/_ec.i SWIG/_evp.i; do
- sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "$i"
+ sed -i -e "s/opensslconf.*\./opensslconf-n${bit}\./" "${S}/$i"
done
fi
}