aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-01-19 15:20:05 -0800
committerTim Orling <ticotimo@gmail.com>2020-01-19 17:53:57 -0800
commit417762c0e1116c5dd31b877c47d01cef791be843 (patch)
tree2eac6cadd626fa45cddd9e63a56983d8a6b43158 /recipes-devtools
parentebca2afbfe243887df212360c2a797cf0a4bc4b1 (diff)
downloadmeta-python2-417762c0e1116c5dd31b877c47d01cef791be843.tar.gz
python-beautifulsoup4: fix target RDEPENDS
* target has run-time dependencies on: - python-html - python-logging Unexpectedly, class-target += override is wiping out RDEPENDS_${PN}, so explicitly add the rest of the run-time dependencies (python-html5lib, python-lxml, python-soupsieve). Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-beautifulsoup4_4.8.1.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-beautifulsoup4_4.8.1.bb b/recipes-devtools/python/python-beautifulsoup4_4.8.1.bb
index 8648271..8ac9c8c 100644
--- a/recipes-devtools/python/python-beautifulsoup4_4.8.1.bb
+++ b/recipes-devtools/python/python-beautifulsoup4_4.8.1.bb
@@ -19,4 +19,14 @@ RDEPENDS_${PN} = "\
${PYTHON_PN}-soupsieve \
"
+# class override, which is not
+# inheriting from above (FIXME?)
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-html5lib \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-lxml \
+ ${PYTHON_PN}-soupsieve \
+"
+
BBCLASSEXTEND = "native nativesdk"