aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-01-20 20:38:50 -0800
committerTim Orling <ticotimo@gmail.com>2020-01-20 20:45:21 -0800
commit23dfb0909444807c5a3b63bd264f0e1a0bf759a5 (patch)
treed8717802ff04ca44e49c546fc7a10bf4bc6abbbf /recipes-devtools
parent901e4394b63157309c65b33fb52a98d35d576d44 (diff)
downloadmeta-python2-23dfb0909444807c5a3b63bd264f0e1a0bf759a5.tar.gz
python-wrapt: add recipe for 1.11.2
Module for decorators, wrappers and monkey patching. Dependency for python-deprecated Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-wrapt_1.11.2.bb29
1 files changed, 24 insertions, 5 deletions
diff --git a/recipes-devtools/python/python-wrapt_1.11.2.bb b/recipes-devtools/python/python-wrapt_1.11.2.bb
index 6a286ab..9a9e2f4 100644
--- a/recipes-devtools/python/python-wrapt_1.11.2.bb
+++ b/recipes-devtools/python/python-wrapt_1.11.2.bb
@@ -1,15 +1,34 @@
-SUMMARY = "A Python module for decorators, wrappers and monkey patching."
-HOMEPAGE = "http://wrapt.readthedocs.org/"
-LICENSE = "BSD-2-Clause"
+SUMMARY = "Module for decorators, wrappers and monkey patching."
+DESCRIPTION = "The aim of the wrapt module is to provide a transparent object \
+proxy for Python, which can be used as the basis for the construction of \
+function wrappers and decorator functions.\
+\
+The wrapt module focuses very much on correctness. It therefore goes way \
+beyond existing mechanisms such as functools.wraps() to ensure that decorators \
+preserve introspectability, signatures, type checking abilities etc. The \
+decorators that can be constructed using this module will work in far more \
+scenarios than typical decorators and provide more predictable and consistent \
+behaviour.\
+\
+To ensure that the overhead is as minimal as possible, a C extension module is \
+used for performance critical components. An automatic fallback to a pure \
+Python implementation is also provided where a target system does not have a \
+compiler to allow the C extension to be compiled."
+HOMEPAGE = "https://github.com/GrahamDumpleton/wrapt"
SECTION = "devel/python"
+
+LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=fdfc019b57affbe1d7a32e3d34e83db4"
+PYPI_PACKAGE = "wrapt"
SRC_URI[md5sum] = "cc15c001b129f81eb2f79b15eb99ffe5"
SRC_URI[sha256sum] = "565a021fd19419476b9362b05eeaa094178de64f8361e44468f9e9d7843901e1"
inherit pypi setuptools
-RDEPENDS_${PN}_class-target += "\
- ${PYTHON_PN}-stringold \
+S = "${WORKDIR}/${PYPI_PACKAGE}-${PV}"
+
+RDEPENDS_${PN}_append_class-target = "\
+ ${PYTHON_PN}-lang \
${PYTHON_PN}-threading \
"