aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-01-20 11:20:10 -0800
committerTim Orling <ticotimo@gmail.com>2020-01-20 11:20:10 -0800
commit1bc3b82a0c64949b12cd0d692edf51800a6a30ba (patch)
treea9457cda786b7fc7f7818646231f20a145537e24 /recipes-devtools
parentf174e9ad770c954573ef1a5d01f25d9f3f25ad51 (diff)
downloadmeta-python2-1bc3b82a0c64949b12cd0d692edf51800a6a30ba.tar.gz
python-engineio: add missing RDEPENDS
For target, missing run-time dependencies: - python-compression (gzip) - python-json - python-logging For all (including native/nativesdk support when desired), missing: - python-six Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/python/python-engineio_3.11.1.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-engineio_3.11.1.bb b/recipes-devtools/python/python-engineio_3.11.1.bb
index d642b0f..3fbba8b 100644
--- a/recipes-devtools/python/python-engineio_3.11.1.bb
+++ b/recipes-devtools/python/python-engineio_3.11.1.bb
@@ -6,9 +6,19 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
-SRC_URI[md5sum] = "bec3b06a112a7f09a0a9c92b627282fe"
-SRC_URI[sha256sum] = "9c9a6035b4b5e5a225f426f846afa14cf627f7571d1ae02167cb703fefd134b7"
+SRC_URI[md5sum] = "327c16ca05e9b0cc4f994b9d35c7f7d7"
+SRC_URI[sha256sum] = "50d108fc7feb7f970e6ebc86733752ebd714545bb5622383e6135bdad45fc9fe"
PYPI_PACKAGE = "python-engineio"
inherit pypi setuptools
+
+RDEPENDS_${PN}_append_class-target = "\
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-six \
+"