aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-15 15:21:57 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 14:38:11 -0700
commit82637a54a768e112381fabbd833d95529a7d23f5 (patch)
tree72ed723aedf40ef5844a42e6e414dbd9fc367e54 /recipes-devtools/python
parente0ce00249d44d2cc6e11089568e892cae94d194e (diff)
downloadmeta-python2-82637a54a768e112381fabbd833d95529a7d23f5.tar.gz
python-constantly: add a recipe for version 15.1.0
(From meta-openembedded commit: caf0cf634c29774dfc1976b3f65f7926dfc064e0) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-constantly.inc11
-rw-r--r--recipes-devtools/python/python-constantly_15.1.0.bb2
2 files changed, 13 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-constantly.inc b/recipes-devtools/python/python-constantly.inc
new file mode 100644
index 0000000..8153504
--- /dev/null
+++ b/recipes-devtools/python/python-constantly.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "Symbolic constants in Python"
+HOMEPAGE = "https://github.com/twisted/constantly"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e393e4ddd223e3a74982efa784f89fd7"
+
+SRC_URI[md5sum] = "f0762f083d83039758e53f8cf0086eef"
+SRC_URI[sha256sum] = "586372eb92059873e29eba4f9dec8381541b4d3834660707faf8ba59146dfc35"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-json"
diff --git a/recipes-devtools/python/python-constantly_15.1.0.bb b/recipes-devtools/python/python-constantly_15.1.0.bb
new file mode 100644
index 0000000..29b15eb
--- /dev/null
+++ b/recipes-devtools/python/python-constantly_15.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-constantly.inc