aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorNicola Lunghi <nick83ola@gmail.com>2019-11-29 02:38:17 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-30 00:13:47 -0800
commitf1a3c363d5e21e7482f6fe7f453cbd9c07b0bb72 (patch)
tree58bbcc64135ff574899bd1b51a635464a451a8ee /recipes-devtools/python
parent857b3cdf06838315152c09b582ab74ab3e3f6158 (diff)
downloadmeta-python2-f1a3c363d5e21e7482f6fe7f453cbd9c07b0bb72.tar.gz
python-configargparse: add package (version 0.15.1)
This module merges the argparse and the configparser functionality and is python3 compatible (From meta-openembedded commit: e875bc8ef59f1257a712174ea11548be1fb74fd9) Signed-off-by: Nicola Lunghi <nick83ola@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-configargparse.inc22
-rw-r--r--recipes-devtools/python/python-configargparse_0.15.1.bb3
2 files changed, 25 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-configargparse.inc b/recipes-devtools/python/python-configargparse.inc
new file mode 100644
index 0000000..17d296f
--- /dev/null
+++ b/recipes-devtools/python/python-configargparse.inc
@@ -0,0 +1,22 @@
+SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables."
+HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
+
+SRC_URI[md5sum] = "aba15b7973b7a70bea86fd69289f8fe3"
+SRC_URI[sha256sum] = "baaf0fd2c1c108d007f402dab5481ac5f12d77d034825bf5a27f8224757bd0ac"
+
+PYPI_PACKAGE = "ConfigArgParse"
+
+inherit pypi
+
+PACKAGECONFIG ?= "yaml"
+PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
diff --git a/recipes-devtools/python/python-configargparse_0.15.1.bb b/recipes-devtools/python/python-configargparse_0.15.1.bb
new file mode 100644
index 0000000..6d64b8d
--- /dev/null
+++ b/recipes-devtools/python/python-configargparse_0.15.1.bb
@@ -0,0 +1,3 @@
+inherit setuptools
+require python-configargparse.inc
+