aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-04-14 13:24:57 +0300
committerTim Orling <ticotimo@gmail.com>2020-04-14 20:16:39 -0700
commitaa4e5723609872f4dd30ba38fcf7380accc88676 (patch)
tree2f6be62eda40e67df2ec25baf2e9b0bb3e2e29a3 /recipes-devtools/python
parent46910494779b0af71303cf51a288e5ec40acc4b0 (diff)
downloadmeta-python2-aa4e5723609872f4dd30ba38fcf7380accc88676.tar.gz
python-docker: move from meta-virtualization
Support for Python 2 has been dropped in meta-virtualization. Move python-docker recipes to meta-python2 for backward compatibility of legacy projects. Dependencies python-docker-pycreds and python-websocket-client should be also present in meta-python2. Upgrade python-docker to 4.2.0, the latest version as of today. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-docker_4.2.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-docker_4.2.0.bb b/recipes-devtools/python/python-docker_4.2.0.bb
new file mode 100644
index 0000000..cf78cf1
--- /dev/null
+++ b/recipes-devtools/python/python-docker_4.2.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "A Python library for the Docker Engine API."
+HOMEPAGE = "https://github.com/docker/docker-py"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34f3846f940453127309b920eeb89660"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "19f803f6a7113301daa5d82a2d1d0c30"
+SRC_URI[sha256sum] = "ddae66620ab5f4bce769f64bcd7934f880c8abe6aa50986298db56735d0f722e"
+
+RDEPENDS_${PN} += " \
+ python-misc \
+ python-six \
+ python-docker-pycreds \
+ python-requests \
+ python-websocket-client \
+ python-backports-ssl \
+"