aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2019-12-06 13:08:10 -0500
committerTim Orling <ticotimo@gmail.com>2020-01-18 21:10:38 -0800
commit89b936ffaebec620cb9ffdc42f23ca76bf3fbe50 (patch)
tree715f5ae2447572a71e3fda2ada386ce34f1d7a28 /recipes-devtools/python
parent45b55e9efbd7d11d2373b5ae226b300fac874da6 (diff)
downloadmeta-python2-89b936ffaebec620cb9ffdc42f23ca76bf3fbe50.tar.gz
python-twisted: add python3-pyserial to RDEPENDS
twisted's internet submodule has serial port functionality that relies on python3-pyserial to be available, but this isn't in twisted's RDEPENDS list, so imports of the serial port functionality will fail: |root@qemux86-64:~# python3 |Python 3.7.5 (default, Dec 5 2019, 23:01:22) |[GCC 9.2.0] on linux |Type "help", "copyright", "credits" or "license" for more information. |>>> import twisted.internet.serialport |Traceback (most recent call last): | File "<stdin>", line 1, in <module> | File "/usr/lib/python3.7/site-packages/twisted/internet/serialport.py", line 21, in <module> | import serial |ModuleNotFoundError: No module named 'serial' |>>> Since the internet submodule is part of the twisted-core split, add python3-pyserial to RDEPENDS for that part of the recipe. (From meta-openembedded commit: 53e62e4e57c701dd546a2e27d8b72b7a4698551a) Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-twisted_19.10.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-twisted_19.10.0.bb b/recipes-devtools/python/python-twisted_19.10.0.bb
index 933ee93..6b7e059 100644
--- a/recipes-devtools/python/python-twisted_19.10.0.bb
+++ b/recipes-devtools/python/python-twisted_19.10.0.bb
@@ -58,7 +58,7 @@ RDEPENDS_${PN} = "\
${PN}-zsh \
"
-RDEPENDS_${PN}-core = "${PYTHON_PN}-core ${PYTHON_PN}-zopeinterface ${PYTHON_PN}-incremental ${PYTHON_PN}-constantly ${PYTHON_PN}-hyperlink ${PYTHON_PN}-automat"
+RDEPENDS_${PN}-core = "${PYTHON_PN}-core ${PYTHON_PN}-zopeinterface ${PYTHON_PN}-incremental ${PYTHON_PN}-constantly ${PYTHON_PN}-hyperlink ${PYTHON_PN}-automat ${PYTHON_PN}-pyserial"
RDEPENDS_${PN}-test = "${PN}"
RDEPENDS_${PN}-conch = "${PN}-core ${PN}-protocols"
RDEPENDS_${PN}-mail = "${PN}-core ${PN}-protocols"