aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-04-27 14:12:39 -0700
committerTim Orling <ticotimo@gmail.com>2020-04-27 14:12:39 -0700
commit2684086f91e7074324081196c8a5f9945d39650e (patch)
treef633cf49802ab9a77d65018a879c12e729b358f6 /recipes-devtools/python
parentb7f6cf1ce299dacaa134dc07d24961a4a4d8c11d (diff)
downloadmeta-python2-2684086f91e7074324081196c8a5f9945d39650e.tar.gz
python-pbr: merge bb and inc files
Merge the contents of the inc file from oe-core to prevent collisions and getting out of sync. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python')
-rw-r--r--recipes-devtools/python/python-pbr_5.4.4.bb14
1 files changed, 11 insertions, 3 deletions
diff --git a/recipes-devtools/python/python-pbr_5.4.4.bb b/recipes-devtools/python/python-pbr_5.4.4.bb
index 9d7d8d7..fb0949e 100644
--- a/recipes-devtools/python/python-pbr_5.4.4.bb
+++ b/recipes-devtools/python/python-pbr_5.4.4.bb
@@ -1,13 +1,21 @@
-inherit setuptools
-# The inc file is in oe-core
-require recipes-devtools/python/python-pbr.inc
+SUMMARY = "Python Build Reasonableness"
+DESCRIPTION = "PBR is a library that injects some useful and sensible default behaviors into your setuptools run"
+HOMEPAGE = "https://pypi.python.org/pypi/pbr"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
SRC_URI[md5sum] = "65cdc32e1a1ff56d481fc15aa8caf988"
SRC_URI[sha256sum] = "139d2625547dbfa5fb0b81daebb39601c478c21956dc57e2e07b74450a8c506b"
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "${PYTHON_PN}-pip"
+
do_install_append() {
if [ -f ${D}${bindir}/pbr ]; then
mv ${D}${bindir}/pbr ${D}${bindir}/pbr-2
fi
}
+BBCLASSEXTEND = "native nativesdk"