aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2020-01-20 17:14:33 +0000
committerTim Orling <ticotimo@gmail.com>2020-01-20 09:33:23 -0800
commit39ddef6a83eb43857f3d46296a30f68ac27e89d5 (patch)
tree5fc63f954a35455338705b061d74c834c21dc200 /recipes-devtools/python/python/05-enable-ctypes-cross-build.patch
parent909fd91182e55a6e5147ab8bf3e6d56e77b9fef0 (diff)
downloadmeta-python2-39ddef6a83eb43857f3d46296a30f68ac27e89d5.tar.gz
python: add 2.7.17 from oe-core
Python 2 ceased being maintained on the 1st January 2020. All users of Python 2 in oe-core have already been ported to Python 3, so in oe-core 390f3eda Python 2 was finally removed from oe-core itself. The following are added to meta-python2 in this commit: - python and python-native 2.7.17 - python-setuptools - The classes pythonnative, pythondir, distutils, setuptools Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python/05-enable-ctypes-cross-build.patch')
-rw-r--r--recipes-devtools/python/python/05-enable-ctypes-cross-build.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch b/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch
new file mode 100644
index 0000000..5cc8742
--- /dev/null
+++ b/recipes-devtools/python/python/05-enable-ctypes-cross-build.patch
@@ -0,0 +1,27 @@
+Rebased for python 2.7.9
+
+Upstream-Status: Inappropriate [embedded specific]
+
+# CTypes need to know the actual host we are building on.
+# Signed-Off: Michael Dietrich <mdt@emdete.de>
+
+Index: Python-2.7.9/setup.py
+===================================================================
+--- Python-2.7.9.orig/setup.py
++++ Python-2.7.9/setup.py
+@@ -2028,12 +2028,12 @@ class PyBuildExt(build_ext):
+
+ # Pass empty CFLAGS because we'll just append the resulting
+ # CFLAGS to Python's; -g or -O2 is to be avoided.
+- cmd = "cd %s && env CFLAGS='' '%s/configure' %s" \
+- % (ffi_builddir, ffi_srcdir, " ".join(config_args))
++ cmd = "(cd %s && autoconf -W cross) && (cd %s && env CFLAGS='' '%s/configure' %s)" \
++ % (ffi_srcdir, ffi_builddir, ffi_srcdir, " ".join(config_args))
+
+ res = os.system(cmd)
+ if res or not os.path.exists(ffi_configfile):
+- print "Failed to configure _ctypes module"
++ print "Failed to configure _ctypes module (res=%d) or missing conffile=%s" % ( res, ffi_configfile )
+ return False
+
+ fficonfig = {}