aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-zopeinterface_4.7.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 21:20:53 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commite361b57cf3d9d6b871d1d165fe455b6ce6075dfb (patch)
tree70d441d87f65d333e22c4b2ecbefd1536e141ccb /recipes-devtools/python/python-zopeinterface_4.7.1.bb
parent0eb37ac4435f3a5f6730a9312b731059ed7e8797 (diff)
downloadmeta-python2-e361b57cf3d9d6b871d1d165fe455b6ce6075dfb.tar.gz
recipes-devtools: merge inc and bb PART I
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop some dangling inc files and some python3 recipes. Enforce Debian naming (python-foo). Only recipes that are executable tools, such as 'gyp' or 'gateone' should be exceptions. When in doubt, search for what the package is named in Debian or Fedora. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-zopeinterface_4.7.1.bb')
-rw-r--r--recipes-devtools/python/python-zopeinterface_4.7.1.bb23
1 files changed, 22 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-zopeinterface_4.7.1.bb b/recipes-devtools/python/python-zopeinterface_4.7.1.bb
index 1bdfd4d..d2ef64f 100644
--- a/recipes-devtools/python/python-zopeinterface_4.7.1.bb
+++ b/recipes-devtools/python/python-zopeinterface_4.7.1.bb
@@ -1,4 +1,25 @@
+SUMMARY = "Interface definitions for Zope products"
+LICENSE = "ZPL-2.1"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e54fd776274c1b7423ec128974bd9d46"
+
+SRC_URI[md5sum] = "1bc66758275c5eb66d169acba3c8e50e"
+SRC_URI[sha256sum] = "4bb937e998be9d5e345f486693e477ba79e4344674484001a0b646be1d530487"
+
+PYPI_PACKAGE = "zope.interface"
+
+PACKAGES =. "${PN}-test "
+
+RPROVIDES_${PN} += "zope-interfaces"
+
+RDEPENDS_${PN}_class-target += "${PYTHON_PN}-datetime"
+
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
+FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
+FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
+FILES_${PN}-test += " \
+ ${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \
+ ${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \
+"
inherit pypi setuptools
-require python-zopeinterface.inc
RDEPENDS_${PN}-test += "python-unittest python-doctest"