aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 21:20:53 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commite361b57cf3d9d6b871d1d165fe455b6ce6075dfb (patch)
tree70d441d87f65d333e22c4b2ecbefd1536e141ccb /recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
parent0eb37ac4435f3a5f6730a9312b731059ed7e8797 (diff)
downloadmeta-python2-e361b57cf3d9d6b871d1d165fe455b6ce6075dfb.tar.gz
recipes-devtools: merge inc and bb PART I
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop some dangling inc files and some python3 recipes. Enforce Debian naming (python-foo). Only recipes that are executable tools, such as 'gyp' or 'gateone' should be exceptions. When in doubt, search for what the package is named in Debian or Fedora. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb')
-rw-r--r--recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb b/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
index 41e85f4..088bffc 100644
--- a/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
+++ b/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
@@ -1,2 +1,19 @@
+DESCRIPTION = "Font Awesome icons packaged for setuptools (easy_install) / pip."
+HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Font-Awesome"
+SECTION = "devel/python"
+LICENSE = "Apache-2"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=313d021898694cd2b0ea6508bdfe51a2"
+
+PYPI_PACKAGE = "XStatic-Font-Awesome"
+
+inherit pypi
+
+SRC_URI[md5sum] = "141a0e9a7e21e82f922573a00ae0c166"
+SRC_URI[sha256sum] = "e01fb480caaa7c7963dcb3328a4700e631bef6070db0e8b685816d220e685f6c"
+
+DEPENDS += " \
+ ${PYTHON_PN}-xstatic \
+ ${PYTHON_PN}-pip \
+ "
+
inherit pypi setuptools
-require python-xstatic-font-awesome.inc