aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-wtforms_2.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-07-10 07:39:07 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:34 +0200
commit8c548656bb74fc159f7825f5923beba2199a9177 (patch)
treec38f11f8f47e4513e5d864aa9b0aa7e48675addf /recipes-devtools/python/python-wtforms_2.1.bb
parent1203bb4dbe7e12af13268ec3490f87b961147844 (diff)
downloadmeta-python2-8c548656bb74fc159f7825f5923beba2199a9177.tar.gz
python-wtforms: add RDEPENDS to work correctly in minimal python environment
(From meta-openembedded commit: 39fdd2e7122db75b1549b2fa0c7bfbf08671cd79) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-wtforms_2.1.bb')
-rw-r--r--recipes-devtools/python/python-wtforms_2.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-wtforms_2.1.bb b/recipes-devtools/python/python-wtforms_2.1.bb
index a5ea283..5ddcb48 100644
--- a/recipes-devtools/python/python-wtforms_2.1.bb
+++ b/recipes-devtools/python/python-wtforms_2.1.bb
@@ -11,3 +11,8 @@ PYPI_PACKAGE = "WTForms"
PYPI_PACKAGE_EXT = "zip"
inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ "