aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-07-10 08:48:00 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-22 21:45:35 +0200
commit179ea1b9215df50c92cf1965519ef08b6c8d3238 (patch)
treec621e9b57a30174b55ff258b5df8d3efe932c136 /recipes-devtools/python/python-vcversioner_2.16.0.0.bb
parentb5662b3fd17a1b0edc3363a445cf6e334f6cd6b6 (diff)
downloadmeta-python2-179ea1b9215df50c92cf1965519ef08b6c8d3238.tar.gz
python-vcversioner: update to version 2.16.0.0
(From meta-openembedded commit: bc892fb0cd52d1c3c7c5b1417d94a0e3f580f60e) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-vcversioner_2.16.0.0.bb')
-rw-r--r--recipes-devtools/python/python-vcversioner_2.16.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-vcversioner_2.16.0.0.bb b/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
new file mode 100644
index 0000000..9308c12
--- /dev/null
+++ b/recipes-devtools/python/python-vcversioner_2.16.0.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python vcversioner, automagically update the project's version"
+HOMEPAGE = "https://github.com/habnabit/vcversioner"
+
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=827a7a91a8d20d3c666b665cd96db8e3"
+
+SRC_URI[md5sum] = "aab6ef5e0cf8614a1b1140ed5b7f107d"
+SRC_URI[sha256sum] = "dae60c17a479781f44a4010701833f1829140b1eeccd258762a74974aa06e19b"
+
+inherit pypi setuptools
+
+do_compile_append() {
+ ${PYTHON} setup.py -q bdist_egg --dist-dir ./
+}
+
+do_install_append() {
+ install -m 0644 ${S}/vcversioner*.egg ${D}/${PYTHON_SITEPACKAGES_DIR}/
+}
+
+BBCLASSEXTEND = "native"