aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-toml_0.10.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 21:51:45 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commit9d6cfe3284388c2e34430680d585891e58259ea8 (patch)
treef7fc97e1cfe84e06bdb9b7afd14ec94a96fb8ab8 /recipes-devtools/python/python-toml_0.10.0.bb
parente361b57cf3d9d6b871d1d165fe455b6ce6075dfb (diff)
downloadmeta-python2-9d6cfe3284388c2e34430680d585891e58259ea8.tar.gz
recipes-devtools: merge inc and bb PART II
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-toml_0.10.0.bb')
-rw-r--r--recipes-devtools/python/python-toml_0.10.0.bb13
1 files changed, 11 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-toml_0.10.0.bb b/recipes-devtools/python/python-toml_0.10.0.bb
index 3c4acce..02006fe 100644
--- a/recipes-devtools/python/python-toml_0.10.0.bb
+++ b/recipes-devtools/python/python-toml_0.10.0.bb
@@ -1,5 +1,14 @@
-inherit setuptools
-require python-toml.inc
+
+SUMMARY = "Python Library for Tom's Obvious, Minimal Language"
+HOMEPAGE = "https://github.com/uiri/toml"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6d6012eea477117abf51c31262a152f8"
+
+SRC_URI[md5sum] = "63fffbe2d632865ec29cd69bfdf36682"
+SRC_URI[sha256sum] = "229f81c57791a41d65e399fc06bf0848bab550a9dfd5ed66df18ce5f05e73d5c"
+
+inherit pypi setuptools
RDEPENDS_${PN} += " \
${PYTHON_PN}-datetime \