aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-snakefood_1.4.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-02-14 23:05:18 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:48 +0100
commit0006851fd7704b0ca1e6ab23b08abb89ba8a61d0 (patch)
treeb6cc28a299e7fa078dee3f47527958b03e51dc28 /recipes-devtools/python/python-snakefood_1.4.bb
parent46273651e0c0c61c8adf3082c4ff22581176483c (diff)
downloadmeta-python2-0006851fd7704b0ca1e6ab23b08abb89ba8a61d0.tar.gz
Update python recipes to use the common pypi package
(From meta-openembedded commit: 9d9a616a392deeb06bf7458902281c9bfeb7f5b6) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-snakefood_1.4.bb')
-rw-r--r--recipes-devtools/python/python-snakefood_1.4.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/recipes-devtools/python/python-snakefood_1.4.bb b/recipes-devtools/python/python-snakefood_1.4.bb
index 1af33d4..e4a6d76 100644
--- a/recipes-devtools/python/python-snakefood_1.4.bb
+++ b/recipes-devtools/python/python-snakefood_1.4.bb
@@ -35,18 +35,13 @@ given the trade-offs, 99% is good enough for 99% of the uses.\
"
AUTHOR = "Martin Blais <blais@furius.ca>"
HOMEPAGE = "http://furius.ca/snakefood"
-SECTION = "devel/python"
LICENSE = "GPL-2.0"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-SRCNAME = "snakefood"
-SRC_URI = "https://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
SRC_URI[md5sum] = "56c88667a33d8909b0aabf2ab6903bdf"
SRC_URI[sha256sum] = "295784668032254e7391ca99ba7060edd3ae4eca1a330ac11627b18ab5923b77"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
+inherit pypi setuptools
RDEPENDS_${PN} = " python-logging python-compiler python-shell"
# the above modules do not have a -native counterpart