aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-smbus_4.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 21:51:45 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commit9d6cfe3284388c2e34430680d585891e58259ea8 (patch)
treef7fc97e1cfe84e06bdb9b7afd14ec94a96fb8ab8 /recipes-devtools/python/python-smbus_4.1.bb
parente361b57cf3d9d6b871d1d165fe455b6ce6075dfb (diff)
downloadmeta-python2-9d6cfe3284388c2e34430680d585891e58259ea8.tar.gz
recipes-devtools: merge inc and bb PART II
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-smbus_4.1.bb')
-rw-r--r--recipes-devtools/python/python-smbus_4.1.bb14
1 files changed, 13 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-smbus_4.1.bb b/recipes-devtools/python/python-smbus_4.1.bb
index 1b95778..d146265 100644
--- a/recipes-devtools/python/python-smbus_4.1.bb
+++ b/recipes-devtools/python/python-smbus_4.1.bb
@@ -1,2 +1,14 @@
+
+SUMMARY = "Set of i2c tools for linux - Python module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://smbusmodule.c;beginline=1;endline=18;md5=46e424fb045901ab25e0f92c28c80055"
+
+SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/i2c-tools-${PV}.tar.gz "
+SRC_URI[md5sum] = "3536237a6b51fb10caacdc3b8a496237"
+SRC_URI[sha256sum] = "ef8f77afc70e7dbfd1171bfeae87a8a7f10074829370ce8d9ccd585a014e0073"
+
+DEPENDS += "i2c-tools"
+
+S = "${WORKDIR}/i2c-tools-${PV}/py-smbus/"
+
inherit distutils
-require python-smbus.inc