aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-slip-dbus_0.6.5.bb
diff options
context:
space:
mode:
authorCallaghan, Dan <dan.callaghan@opengear.com>2019-01-30 07:22:08 +0000
committerKhem Raj <raj.khem@gmail.com>2019-02-01 06:57:14 -0800
commit793c7089259c4c6ee39897afe4717c340e56e90d (patch)
tree791e85ca12f9caea77a72b351ffe6a7f22115cc1 /recipes-devtools/python/python-slip-dbus_0.6.5.bb
parentfe74471b03a2cb2fdcc0318e953384bcbc084465 (diff)
downloadmeta-python2-793c7089259c4c6ee39897afe4717c340e56e90d.tar.gz
python-slip-dbus: add a python3 version of the recipe
(From meta-openembedded commit: 53cb161e6c475708b9ca3a1ec570592c868ca392) Signed-off-by: Dan Callaghan <dan.callaghan@opengear.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-slip-dbus_0.6.5.bb')
-rw-r--r--recipes-devtools/python/python-slip-dbus_0.6.5.bb31
1 files changed, 1 insertions, 30 deletions
diff --git a/recipes-devtools/python/python-slip-dbus_0.6.5.bb b/recipes-devtools/python/python-slip-dbus_0.6.5.bb
index c2675cb..330fa1b 100644
--- a/recipes-devtools/python/python-slip-dbus_0.6.5.bb
+++ b/recipes-devtools/python/python-slip-dbus_0.6.5.bb
@@ -1,31 +1,2 @@
-SUMMARY = "Convenience functions for dbus services in Python 2.x"
-HOMEPAGE = "https://github.com/nphilipp/python-slip"
-DESCRIPTION = "\
-The Simple Library for Python 2.x packages contain miscellaneous code for \
-convenience, extension and workaround purposes. \
-\
-This package provides slip.dbus.service.Object, which is a dbus.service.Object \
-derivative that ends itself after a certain time without being used and/or if \
-there are no clients anymore on the message bus, as well as convenience \
-functions and decorators for integrating a dbus service with PolicyKit."
-
-SECTION = "devel/python"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
-SRCNAME = "python-slip"
-
-SRC_URI = "https://github.com/nphilipp/${SRCNAME}/releases/download/${SRCNAME}-${PV}/${SRCNAME}-${PV}.tar.bz2"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
inherit setuptools
-
-SRC_URI[md5sum] = "28ae5f93853466c44ec96706ba2a1eb4"
-SRC_URI[sha256sum] = "c726c086f0dd93a0ac7a0176f383a12af91b6657b78a301e3f5b25d9f8d4d10b"
-
-do_compile_prepend() {
- sed -e 's/@VERSION@/${PV}/g' setup.py.in > setup.py
-}
-
-# http://errors.yoctoproject.org/Errors/Details/184713/
-# python-native/python: can't open file 'setup.py': [Errno 2] No such file or directory
-CLEANBROKEN = "1"
+require python-slip-dbus.inc