aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-singledispatch_3.4.0.3.bb
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2016-06-02 23:12:47 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:28 +0200
commit545b522a69dba3b171b1d928caa0fa2de8b52fb7 (patch)
tree69874f8c93c2dcea9ca714567cd2927eb1e39050 /recipes-devtools/python/python-singledispatch_3.4.0.3.bb
parent6d99c09a40224bf6d6fe6094502a90b830510ba5 (diff)
downloadmeta-python2-545b522a69dba3b171b1d928caa0fa2de8b52fb7.tar.gz
python-singledispatch: initial recipe for version 3.4.0.3
This package backports functools.singledispatch from Python 3.4 to earlier Python versions. It is being added as one of the two missing backport modules that Tornado 4.3 needs in order to prevent tornado/gen.py from bombing on import errors when running on python2 rather than python3.4 ImportError: No module named singledispatch (From meta-openembedded commit: 7650008ed9294ec272ecbc6f5a4ef8872830e2e1) Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-singledispatch_3.4.0.3.bb')
-rw-r--r--recipes-devtools/python/python-singledispatch_3.4.0.3.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-singledispatch_3.4.0.3.bb b/recipes-devtools/python/python-singledispatch_3.4.0.3.bb
new file mode 100644
index 0000000..87f46e5
--- /dev/null
+++ b/recipes-devtools/python/python-singledispatch_3.4.0.3.bb
@@ -0,0 +1,13 @@
+SUMMARY = "functools.singledispatch from Python 3.4"
+DESCRIPTION = "PEP 443 proposed to expose a mechanism in the functools standard library module \
+in Python 3.4 that provides a simple form of generic programming known as single-dispatch \
+generic functions. This library is a backport of this functionality to Python 2.6 - 3.3"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=ee3cd67264adc7eb07981f3644dc17dc"
+
+SRC_URI[md5sum] = "af2fc6a3d6cc5a02d0bf54d909785fcb"
+SRC_URI[sha256sum] = "5b06af87df13818d14f08a028e42f566640aef80805c3b50c5056b086e3c2b9c"
+
+PYPI_PACKAGE = "singledispatch"
+inherit pypi setuptools