aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-sh_1.12.14.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 21:51:45 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commit9d6cfe3284388c2e34430680d585891e58259ea8 (patch)
treef7fc97e1cfe84e06bdb9b7afd14ec94a96fb8ab8 /recipes-devtools/python/python-sh_1.12.14.bb
parente361b57cf3d9d6b871d1d165fe455b6ce6075dfb (diff)
downloadmeta-python2-9d6cfe3284388c2e34430680d585891e58259ea8.tar.gz
recipes-devtools: merge inc and bb PART II
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-sh_1.12.14.bb')
-rw-r--r--recipes-devtools/python/python-sh_1.12.14.bb33
1 files changed, 31 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-sh_1.12.14.bb b/recipes-devtools/python/python-sh_1.12.14.bb
index 7cb5140..2eba7b6 100644
--- a/recipes-devtools/python/python-sh_1.12.14.bb
+++ b/recipes-devtools/python/python-sh_1.12.14.bb
@@ -1,8 +1,37 @@
-require python-sh.inc
-inherit setuptools
+
+SUMMARY = "Python subprocess replacement"
+HOMEPAGE = "https://github.com/amoffat/sh"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6"
+
+SRC_URI[md5sum] = "a8351aef25d25f707c17e0a7a6280251"
+SRC_URI[sha256sum] = "b52bf5833ed01c7b5c5fb73a7f71b3d98d48e9b9b8764236237bdc7ecae850fc"
+
+PYPI_PACKAGE = "sh"
+
+inherit pypi setuptools
RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-codecs \
${PYTHON_PN}-contextlib \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
${PYTHON_PN}-lang \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-resource \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-tests \
${PYTHON_PN}-textutils \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
"
+
+# WARNING: We were unable to map the following python package/module
+# dependencies to the bitbake packages which include them:
+# coverage - only used in test and there is a check to see if it is
+# available before importing.
+# queue - part of threading
+# signal - part of core in python3. not sure how it is imported in python2.
+# No complants in compiling.
+