aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-serpent_1.28.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 21:51:45 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commit9d6cfe3284388c2e34430680d585891e58259ea8 (patch)
treef7fc97e1cfe84e06bdb9b7afd14ec94a96fb8ab8 /recipes-devtools/python/python-serpent_1.28.bb
parente361b57cf3d9d6b871d1d165fe455b6ce6075dfb (diff)
downloadmeta-python2-9d6cfe3284388c2e34430680d585891e58259ea8.tar.gz
recipes-devtools: merge inc and bb PART II
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-serpent_1.28.bb')
-rw-r--r--recipes-devtools/python/python-serpent_1.28.bb15
1 files changed, 13 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-serpent_1.28.bb b/recipes-devtools/python/python-serpent_1.28.bb
index 0db3cf9..a225c9b 100644
--- a/recipes-devtools/python/python-serpent_1.28.bb
+++ b/recipes-devtools/python/python-serpent_1.28.bb
@@ -1,2 +1,13 @@
-inherit setuptools
-require python-serpent.inc
+SUMMARY = "Serialization based on ast.literal_eval"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=5cd70632b6cdb96df9ddaf6a4ce619e6"
+
+SRC_URI[md5sum] = "15ef8b67c76a6d19bac9c16731a1e62a"
+SRC_URI[sha256sum] = "f306336ca09aa38e526f3b03cab58eb7e45af09981267233167bcf3bfd6436ab"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ "