aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-requests_2.23.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-04-09 20:51:36 +0300
committerTim Orling <ticotimo@gmail.com>2020-04-10 14:41:41 -0700
commit8054d5bb2c08af105c2a8bcbe0010aa320e5bd95 (patch)
tree4d3f4529e184651370b691725a8eb61e259f6540 /recipes-devtools/python/python-requests_2.23.0.bb
parent231c3d74cfcf734c3415e86ea8dd97f73ddced9d (diff)
downloadmeta-python2-8054d5bb2c08af105c2a8bcbe0010aa320e5bd95.tar.gz
python-requests: Upgrade 2.22.0 to 2.23.0
Upgrade python-requests to version 2.23.0. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Upstream release notes: 2.23.0 (2020-02-19) * Improvements - Remove defunct reference to prefetch in Session __attrs__ (#5110) * Bugfixes - Requests no longer outputs password in basic auth usage warning. (#5099) * Dependencies - Pinning for chardet and idna now uses major version instead of minor. This hopefully reduces the need for releases everytime a dependency is updated. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-requests_2.23.0.bb')
-rw-r--r--recipes-devtools/python/python-requests_2.23.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-requests_2.23.0.bb b/recipes-devtools/python/python-requests_2.23.0.bb
new file mode 100644
index 0000000..52df65c
--- /dev/null
+++ b/recipes-devtools/python/python-requests_2.23.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Python HTTP for Humans."
+DESCRIPTION = "Requests allows you to send HTTP/1.1 requests extremely easily. \
+There’s no need to manually add query strings to your URLs, or to form-encode \
+your POST data. Keep-alive and HTTP connection pooling are 100% automatic, \
+thanks to urllib3."
+HOMEPAGE = "http://python-requests.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=19b6be66ed463d93fa88c29f7860bcd7"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-requests:"
+
+SRC_URI[md5sum] = "abfdc28db1065bbd0bc32592ac9d27a6"
+SRC_URI[sha256sum] = "b3f43d496c6daba4493e7c431722aeb7dbc6288f52a6e04e7b6023b0247817e6"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-ndg-httpsclient \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-pysocks \
+ ${PYTHON_PN}-urllib3 \
+ ${PYTHON_PN}-zlib \
+"
+
+CVE_PRODUCT = "requests"
+
+BBCLASSEXTEND = "native nativesdk"
+