aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pyyaml.inc
diff options
context:
space:
mode:
authorPascal Bach <pascal.bach@nextrem.ch>2017-01-05 18:12:31 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-25 15:58:54 +0100
commit654a9da7199c20e1700c7b30a6b0589b7fc3c709 (patch)
treecba75bed96c5b92b91a4c62263a2129601d5dfe4 /recipes-devtools/python/python-pyyaml.inc
parent5fa5e3ba7f98a0e5176f30a02bc9d4d0615e614b (diff)
downloadmeta-python2-654a9da7199c20e1700c7b30a6b0589b7fc3c709.tar.gz
python-yaml: provide both python2 and python3 package
Further the recipe is simplified by using the pypi and setuptools class. The custom setup.py is no onger necessary. (From meta-openembedded commit: 1161ab8f8dda272eb5d09917446cc5b971be1335) Signed-off-by: Pascal Bach <pascal.bach@nextrem.ch> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pyyaml.inc')
-rwxr-xr-xrecipes-devtools/python/python-pyyaml.inc14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyyaml.inc b/recipes-devtools/python/python-pyyaml.inc
new file mode 100755
index 0000000..41321ca
--- /dev/null
+++ b/recipes-devtools/python/python-pyyaml.inc
@@ -0,0 +1,14 @@
+SUMMARY = "Python support for YAML"
+HOMEPAGE = "http://www.pyyaml.org"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6015f088759b10e0bc2bf64898d4ae17"
+DEPENDS = "libyaml ${PYTHON_PN}-cython-native"
+
+PYPI_PACKAGE = "PyYAML"
+inherit pypi
+
+SRC_URI[md5sum] = "4c129761b661d181ebf7ff4eb2d79950"
+SRC_URI[sha256sum] = "592766c6303207a20efc445587778322d7f73b161bd994f227adaa341ba212ab"
+
+BBCLASSEXTEND = "native nativesdk"