aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pytz_2019.3.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 07:36:38 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:03:31 -0800
commit0890fb548d98199da117816b33fdbbf5c6c83547 (patch)
tree6128f33298798f3d12aace67963e355e243d7483 /recipes-devtools/python/python-pytz_2019.3.bb
parent9d6cfe3284388c2e34430680d585891e58259ea8 (diff)
downloadmeta-python2-0890fb548d98199da117816b33fdbbf5c6c83547.tar.gz
recipes-devtools: merge inc and bb PART III
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pytz_2019.3.bb')
-rwxr-xr-xrecipes-devtools/python/python-pytz_2019.3.bb22
1 files changed, 20 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-pytz_2019.3.bb b/recipes-devtools/python/python-pytz_2019.3.bb
index f2ffc59..6847333 100755
--- a/recipes-devtools/python/python-pytz_2019.3.bb
+++ b/recipes-devtools/python/python-pytz_2019.3.bb
@@ -1,2 +1,20 @@
-inherit setuptools
-require python-pytz.inc
+SUMMARY = "World timezone definitions, modern and historical"
+HOMEPAGE = "http://pythonhosted.org/pytz"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4878a915709225bceab739bdc2a18e8d"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "c3d84a465fc56a4edd52cca8873ac0df"
+SRC_URI[sha256sum] = "b02c06db6cf09c12dd25137e563b31700d3b80fcc4ad23abb7a315f2789819be"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"