aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pytest-runner_5.2.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 07:36:38 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:03:31 -0800
commit0890fb548d98199da117816b33fdbbf5c6c83547 (patch)
tree6128f33298798f3d12aace67963e355e243d7483 /recipes-devtools/python/python-pytest-runner_5.2.bb
parent9d6cfe3284388c2e34430680d585891e58259ea8 (diff)
downloadmeta-python2-0890fb548d98199da117816b33fdbbf5c6c83547.tar.gz
recipes-devtools: merge inc and bb PART III
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pytest-runner_5.2.bb')
-rw-r--r--recipes-devtools/python/python-pytest-runner_5.2.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-pytest-runner_5.2.bb b/recipes-devtools/python/python-pytest-runner_5.2.bb
index 1765a73..55fda2f 100644
--- a/recipes-devtools/python/python-pytest-runner_5.2.bb
+++ b/recipes-devtools/python/python-pytest-runner_5.2.bb
@@ -1,5 +1,19 @@
-inherit setuptools
-require python-pytest-runner.inc
+SUMMARY = "Invoke py.test as distutils command with dependency resolution"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a33f38bbf47d48c70fe0d40e5f77498e"
+
+SRC_URI[md5sum] = "e5f66b8e8e87f62c59631c35c919d321"
+SRC_URI[sha256sum] = "96c7e73ead7b93e388c5d614770d2bae6526efd997757d3543fe17b557a0942b"
+
+inherit pypi setuptools
+
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
+ ${PYTHON_PN}-io"
# Dependency only exists for python2
RDEPENDS_${PN} += "python-argparse python-compiler"
+
+BBCLASSEXTEND = "native nativesdk"