aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pyrex_0.9.9.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:56:58 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:26 +0200
commit77a06fa085aff8d95288a15ce847523e05c1762a (patch)
tree821ed29ae0982ed7db88d224f1a559f2358281c0 /recipes-devtools/python/python-pyrex_0.9.9.bb
parent170b637061e747e034f2f23fe57a49af037e400e (diff)
downloadmeta-python2-77a06fa085aff8d95288a15ce847523e05c1762a.tar.gz
python-pyrex: add a recipe
This is moved from oe-core. (From meta-openembedded commit: 4f93338b18caf5c9d2053c0f4a0f9d5706285f3f) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pyrex_0.9.9.bb')
-rw-r--r--recipes-devtools/python/python-pyrex_0.9.9.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyrex_0.9.9.bb b/recipes-devtools/python/python-pyrex_0.9.9.bb
new file mode 100644
index 0000000..c4dd2e6
--- /dev/null
+++ b/recipes-devtools/python/python-pyrex_0.9.9.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Language for writing Python extension modules"
+DESCRIPTION = "Pyrex is a language specially designed for writing Python extension modules. \
+It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \
+and the messy, low-level world of C."
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=771d472f53f933033f57eeee7808e5bd"
+SRCNAME = "Pyrex"
+PR = "r4"
+
+SRC_URI = "\
+ http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://pyrex-fix-optimized-mode.patch \
+"
+
+SRC_URI[md5sum] = "515dee67d15d4393841e2d60e8341947"
+SRC_URI[sha256sum] = "5f87df06831d0b3412eb4bc9d3fc2ee7bfae1b913d7da8c23ab2bf5699fb6b50"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+FILES_${PN} += "${datadir}${base_libdir}/${PYTHON_DIR}/site-packages/Pyrex/Compiler/Lexicon.pickle"