aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pyperf_1.7.0.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-01-02 15:35:17 +0800
committerTim Orling <ticotimo@gmail.com>2020-01-22 18:49:23 -0800
commit97f2eb13468449219f44fae120a25b7c2d170b94 (patch)
treec08df6fc99f792aeedb2a6325b73169c9211489d /recipes-devtools/python/python-pyperf_1.7.0.bb
parent01c7268b8834496ea6759e3216f4463b234699a0 (diff)
downloadmeta-python2-97f2eb13468449219f44fae120a25b7c2d170b94.tar.gz
python-pyperf: upgrade 1.6.1 -> 1.7.0
(From meta-openembedded commit: b0457789777ae8b1c1d24a09381a184ff94d60b7) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pyperf_1.7.0.bb')
-rw-r--r--recipes-devtools/python/python-pyperf_1.7.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyperf_1.7.0.bb b/recipes-devtools/python/python-pyperf_1.7.0.bb
new file mode 100644
index 0000000..20aa7a3
--- /dev/null
+++ b/recipes-devtools/python/python-pyperf_1.7.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A toolkit to write, run and analyze benchmarks"
+DESCRIPTION = " \
+The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
+Features: \
+ * Simple API to run reliable benchmarks \
+ * Automatically calibrate a benchmark for a time budget. \
+ * Spawn multiple worker processes. \
+ * Compute the mean and standard deviation. \
+ * Detect if a benchmark result seems unstable. \
+ * JSON format to store benchmark results. \
+ * Support multiple units: seconds, bytes and integer. \
+"
+HOMEPAGE = "https://github.com/vstinner/pyperf"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
+
+SRC_URI[md5sum] = "e30b67b62a4e30e4504352d0778c622c"
+SRC_URI[sha256sum] = "0d214aa65e085d3e4108a36152cb12f7cd0f4e7fda93b5134b43a9687c975786"
+
+inherit pypi setuptools
+
+PYPI_PACKAGE = "pyperf"
+
+DEPENDS += "${PYTHON_PN}-six-native"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-statistics"