aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pyopenssl_19.1.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2019-12-02 03:07:21 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-10 21:15:58 -0800
commit291ebc969b6a920e96ef1d209f0e7ee1f0f47a27 (patch)
tree40885f8646938d923dcbdf86a7521a2d8937e7ef /recipes-devtools/python/python-pyopenssl_19.1.0.bb
parent1fbe87190a19880bda5725b8eed8b35bba99ba42 (diff)
downloadmeta-python2-291ebc969b6a920e96ef1d209f0e7ee1f0f47a27.tar.gz
python-pyopenssl: upgrade 19.0.0 -> 19.1.0
(From meta-openembedded commit: 04ec002b1025e1dce2514b865af4976c7991c226) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pyopenssl_19.1.0.bb')
-rw-r--r--recipes-devtools/python/python-pyopenssl_19.1.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyopenssl_19.1.0.bb b/recipes-devtools/python/python-pyopenssl_19.1.0.bb
new file mode 100644
index 0000000..634c276
--- /dev/null
+++ b/recipes-devtools/python/python-pyopenssl_19.1.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Simple Python wrapper around the OpenSSL library"
+HOMEPAGE = "https://pyopenssl.org/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS += "openssl ${PYTHON_PN}-cryptography"
+
+SRC_URI[md5sum] = "d9804fedbd1eb0c7d9243397b1fbf972"
+SRC_URI[sha256sum] = "9a24494b2602aaf402be5c9e30a0b82d4a5c67528fe8fb475e3f3bc00dd69507"
+
+PYPI_PACKAGE = "pyOpenSSL"
+
+inherit pypi setuptools
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
+
+RDEPENDS_${PN}_class-target = " \
+ ${PYTHON_PN}-cryptography \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-threading \
+"
+RDEPENDS_${PN}-tests = "${PN}"
+
+BBCLASSEXTEND = "native nativesdk"