aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pyopenssl_0.13.bb
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2015-03-27 23:21:02 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-13 12:55:49 +0200
commite9c2607c6f6181ed632086b9e5598a5dd4fc6dd3 (patch)
treeb57d81bf6d02de8d631e39420ee127b9c0628ad4 /recipes-devtools/python/python-pyopenssl_0.13.bb
parentade2ece90336f3ad2922c7a4b16888572f6b300a (diff)
downloadmeta-python2-e9c2607c6f6181ed632086b9e5598a5dd4fc6dd3.tar.gz
python-pyopenssl: Downgrade to 0.13
Version 0.14 depends python-cryptography, which is currently unavailable in meta-openembedded. (From meta-openembedded commit: 6a0641398d4b161253afe9bfd744ce0fd5950bc6) Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pyopenssl_0.13.bb')
-rw-r--r--recipes-devtools/python/python-pyopenssl_0.13.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pyopenssl_0.13.bb b/recipes-devtools/python/python-pyopenssl_0.13.bb
new file mode 100644
index 0000000..cf9d73e
--- /dev/null
+++ b/recipes-devtools/python/python-pyopenssl_0.13.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Simple Python wrapper around the OpenSSL library"
+SECTION = "devel/python"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCNAME = "pyOpenSSL"
+
+DEPENDS = "openssl"
+PE = "1"
+
+SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz \
+ file://x509_revoked_dup.patch"
+SRC_URI[md5sum] = "767bca18a71178ca353dff9e10941929"
+SRC_URI[sha256sum] = "21e12b03abaa0e04ecc8cd9c251598f71bae11c9f385304234e4ea5618c6163b"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
+
+RDEPENDS_${PN} = "python-threading"
+RDEPENDS_${PN}-tests = "${PN}"