aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pymongo_3.10.1.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-01-19 14:11:02 +0800
committerTim Orling <ticotimo@gmail.com>2020-01-25 00:13:13 -0800
commit59ff56ad37448a8c9c196cc065199be6c038cba8 (patch)
treee9f1b08fc43c16f5742aad86a3a7fff8924313f0 /recipes-devtools/python/python-pymongo_3.10.1.bb
parentce5ed5782d1daacfe586187f68992fbd0cc09d52 (diff)
downloadmeta-python2-59ff56ad37448a8c9c196cc065199be6c038cba8.tar.gz
python-pymongo: upgrade 3.10.0 -> 3.10.1
(From meta-openembedded commit: e495d0da7b2dc45c44f3ceb8921112408de2963d) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pymongo_3.10.1.bb')
-rw-r--r--recipes-devtools/python/python-pymongo_3.10.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-pymongo_3.10.1.bb b/recipes-devtools/python/python-pymongo_3.10.1.bb
new file mode 100644
index 0000000..3a17320
--- /dev/null
+++ b/recipes-devtools/python/python-pymongo_3.10.1.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
+DESCRIPTION = "\
+The PyMongo distribution contains tools for interacting with MongoDB \
+database from Python. The bson package is an implementation of the BSON \
+format for Python. The pymongo package is a native Python driver for \
+MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
+HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI[md5sum] = "e31b9c0190c9eaf1f792d0277b2a8ebe"
+SRC_URI[sha256sum] = "993257f6ca3cde55332af1f62af3e04ca89ce63c08b56a387cdd46136c72f2fa"
+
+inherit pypi setuptools
+
+PACKAGES =+ "${PYTHON_PN}-bson"
+
+FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
+
+RDEPENDS_${PYTHON_PN}-bson += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-threading \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-bson \
+ ${PYTHON_PN}-pprint \
+"